Page MenuHomePhabricator

"patrol" API endpoint "tags" parameter is unused
Closed, InvalidPublic

Description

I'm not sure how to make a bug out of this, but I want to note that nobody is taking advantage of the "tags" parameter on patrol actions, which will create ChangeTags. The API help makes it look like we should be specifying a tool or bot identity here, which might be useful, but a query shows that we never do so. The feature was added in January 2016.

SELECT
  *
FROM
  wmf_raw.ApiAction
WHERE year = 2018
  AND month = 6
  AND params['action'] = 'patrol'
  AND params['tags'] is not null
;

-> no rows selected.

I'd suggest either removing the feature or publicizing it better...

Event Timeline

awight created this task.Jun 25 2018, 1:04 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 25 2018, 1:04 PM
TTO added subscribers: Anomie, TTO.Jun 25 2018, 1:50 PM

All logged actions are supposed to allow tagging. Not many people have taken advantage of this feature for various reasons, and I would imagine uptake has been limited to a few common log actions (probably upload and perhaps delete and block as well). But I don't see this feature creating a significant maintenance burden.

And in any case I don't see why patrol should be excluded from tagging while other logged actions are included...

@TTO Makes sense to me... Maybe part of the issue is that the documentation implies that we should be tagging actions with something like a user-agent string, but with no explanation about why that might be a useful thing to do, and with a finite number of tags, we can't leave a proper user-agent, can't include the software version, and so on.

awight triaged this task as Lowest priority.Jun 25 2018, 2:51 PM

Turning this into a minor cleanup thing...

awight closed this task as Invalid.Jun 25 2018, 2:52 PM

Actually, throwing it out.

Vvjjkkii renamed this task from "patrol" API endpoint "tags" parameter is unused to pcaaaaaaaa.Jul 1 2018, 1:02 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii raised the priority of this task from Lowest to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
CommunityTechBot renamed this task from pcaaaaaaaa to "patrol" API endpoint "tags" parameter is unused.Jul 2 2018, 10:13 AM
CommunityTechBot closed this task as Invalid.
CommunityTechBot lowered the priority of this task from High to Lowest.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added a subscriber: Aklapper.