Page MenuHomePhabricator

MediaWiki 1.31 Release notes states that THIS IS NOT A RELEASE YET!
Closed, InvalidPublic

Description

MediaWiki 1.31 has been released some days ago, but the release notes state that this is not a release yet

https://phabricator.wikimedia.org/source/mediawiki/browse/REL1_31/RELEASE-NOTES-1.31

Looks like the release team that handles the release of new versions didn't follow the Release Checklist thoroughly, because there's an item about Release notes there: https://www.mediawiki.org/wiki/Release_checklist#Prepare_local_system

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 26 2018, 9:23 AM

I've added a reminder of the "THIS IS NOT A RELEASE YET!" text on the comments section, just in case, because it's not the first time something like this happens :)

@Ciencia_Al_Poder This is normal. On the 1.31 tag, RELEASE-NOTES-1.31 file doesn't have THIS IS NOT A RELEASE YET!. I guess that the latest commit contains this sentence for 1.31.1.

Kghbln added a subscriber: Kghbln.Jun 26 2018, 1:26 PM

The issue is that we link to the master version of the "RELEASE-NOTES-1.31" file all over MediaWiki.org so the end user will always see "THIS IS NOT A RELEASE YET!". Perhaps it is just a matter of creating a better logic by directing the link to the latest release tag of the respective branch to avoid this. Currently this is very confusing what we are doing and this is why this pop up over and over again. Today I needed about half an hour to figure this out after finally waking up. :|

Lziobro added a subscriber: Lziobro.EditedJun 26 2018, 7:13 PM

The phrase was removed by 5cfc9accca2c but added back by e7f2209acf7b (which I assume is for 1.31.1).

Jdforrester-WMF closed this task as Invalid.Jun 26 2018, 7:17 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

It is correct that REL1_31 is not a release yet (it will eventually be branched as MW 1.31.1, but right now it's MW 1.31.0 plus four commits that will end up in it:

$ git log --topo-order --no-merges "1.31.0"..origin/REL1_31

commit 63a4e21bbd757ee48a04a9c81f78864eab628282 (origin/fundraising/REL1_31, origin/REL1_31)
Author: Edward Chernenko <edwardspec@gmail.com>
Date:   2018-06-20 02:43:01 +0300

    Update git submodules

    * Update skins/MonoBook from branch 'REL1_31'
      to 53a78553e4b6cb091df318bf70291330f1425429
      - Missing 'class' in "newtalk" notification

        MonoBookTemplate incorrectly calls getIfExists() for newtalk/undelete:
        attributes of wrapper <div> must be under the 'parameters' key.

        Change-Id: I5392477d493174b0b5598927bfbcec2029b0987e
        (cherry picked from commit 73ad6a7835b587035e127d32d4667ba16e43ad03)

commit 0e7eb691d3dac19b5743c3251bc1621254ae32f1
Author: Paladox <thomasmulhall410@yahoo.com>
Date:   2018-06-16 21:27:22 +0000

    Update git submodules

    * Update skins/Timeless from branch 'REL1_31'
      to 6860d4d96db3bfcc92172f08ddfe4a2344229937
      - Fix sidebar closing on iOS

        this follows this fix [1]

        [1] https://stackoverflow.com/questions/11397028/document-click-function-for-touch-device

        Bug: T161470
        Change-Id: I20e6a0e18a239131b94e4ab949b7784f241e4d40

commit b1fe6389a9a09ebc4f8f670a60bcbd37897b657a
Author: Isarra <zhorishna@gmail.com>
Date:   2018-06-13 20:52:32 +0000

    Update git submodules

    * Update skins/Timeless from branch 'REL1_31'
      to 2126f76540981047f072d672be5c15475a2556cf
      - Remove nonfunctional jquery mobile stuff

        Does not appear to work, and is possibly breaking things elsewise as
        well. In particular: chrome text selection in general, possibly iphone
        support?

        May or may not resolve the following; please test (does seem to
        effectively resolve T183215, for now, at least, but dunno at all about
        the other two.):

        Bug: T161470
        Bug: T183215
        Bug: T188387
        Change-Id: I2d4aae98fe47bce5a873bc44b6cea58f111f5086

commit e7f2209acf7b810459b95235679cacca8cb8c7b9
Author: MarcoAurelio <maurelio@tools.wmflabs.org>
Date:   2018-06-14 13:00:20 +0200

    Add Extension:Nuke submodule to REL1_31

    Bug: T197229
    Change-Id: I6dad2c00c7480894beeaf8979b8d66f4cc32cc89

Quite a lot of links on the branch info pages to the release notes were broken due to different reasons so I just created a template RELEASE-NOTES. If someone has a better solution please go for it.

Vvjjkkii renamed this task from MediaWiki 1.31 Release notes states that THIS IS NOT A RELEASE YET! to baaaaaaaaa.Jul 1 2018, 1:03 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii triaged this task as High priority.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed a subscriber: Aklapper.
MacFan4000 closed this task as Resolved.Jul 1 2018, 7:55 PM
MacFan4000 claimed this task.
MacFan4000 raised the priority of this task from High to Needs Triage.
MacFan4000 added a subscriber: Aklapper.
Restricted Application added a project: User-MacFan4000. · View Herald TranscriptJul 1 2018, 7:55 PM
MacFan4000 removed MacFan4000 as the assignee of this task.Jul 1 2018, 7:55 PM
MacFan4000 removed a project: User-MacFan4000.
MacFan4000 added a subscriber: MacFan4000.
MacFan4000 removed a subscriber: MacFan4000.
JJMC89 changed the task status from Resolved to Invalid.Jul 1 2018, 7:57 PM
MacFan4000 changed the task status from Invalid to Resolved.Jul 1 2018, 7:57 PM
MacFan4000 changed the task status from Resolved to Invalid.
MacFan4000 updated the task description. (Show Details)
JJMC89 renamed this task from baaaaaaaaa to MediaWiki 1.31 Release notes states that THIS IS NOT A RELEASE YET!.Jul 1 2018, 7:57 PM