Page MenuHomePhabricator

abusefilter-log-hide-reason dropdown should be in wiki content language
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:

  • Go to Special:AbuseLog and try to hide (oversight) a log entry.
  • A dropdown with reasons is presented to the user.

Actual Results:

  • The dropdown is displayed on the language the user has set in their preferences.

Expected Results:

  • The dropdown should be displayed in the wiki content language.

Thank you.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 26 2018, 9:45 AM

Change 442088 had a related patch set uploaded (by Daimona Eaytoy; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@master] Use content language for the revdel dropdown

https://gerrit.wikimedia.org/r/442088

Daimona claimed this task.Jun 26 2018, 12:37 PM
Huji added a subscriber: Huji.Jun 26 2018, 4:43 PM

I don't get it. First of all, Special:AbuseFilter/log doesn't have a hide/suppress option (it is a log of changes to filters, why would it have suppress option anyway?)

And also, why would the intended target have to be in content language?

@Huji AbuseLog is indeed suppressable, only at oversight-level. The dropdown should be in the language of the wiki where it's used, since it provides standard reason to be used in that wiki's logs. The same thing goes for the same message used on MW core suppression.

Huji added a comment.Jun 26 2018, 6:15 PM

So you mean Spdecial:AbuseLog (not Special:AbuseFilter/log, as stated above). I will fix it!

Huji updated the task description. (Show Details)Jun 26 2018, 6:15 PM

Change 442162 had a related patch set uploaded (by Mikepipo; owner: Daimona Eaytoy):
[mediawiki/extensions/AbuseFilter@wmf/1.32.0-wmf.10] Use content language for the revdel dropdown

https://gerrit.wikimedia.org/r/442162

Yeah, I didn't even notice the wrong naming, I just looked at the message :-) BTW I don't feel the backport as necessary

Change 442088 merged by jenkins-bot:
[mediawiki/extensions/AbuseFilter@master] Use content language for the revdel dropdown

https://gerrit.wikimedia.org/r/442088

Huji closed this task as Resolved.Jun 26 2018, 7:42 PM
Huji removed a project: Patch-For-Review.

Change 442162 abandoned by Huji:
Use content language for the revdel dropdown

Reason:
It can wait for normal deployment next week.

https://gerrit.wikimedia.org/r/442162