Page MenuHomePhabricator

[Regression wmf.8?] The textbox size inside Add template dialog is too small on Firefox
Closed, ResolvedPublic

Description

The textbox size inside Add template dialog is too small on Firefox. Not sure since when it's broken.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 26 2018, 11:26 PM
DLynch renamed this task from [Regression wmf.8?] The textbox size inside Add citation dialog is too small on Firefox to [Regression wmf.8?] The textbox size inside Add template dialog is too small on Firefox.Jun 27 2018, 4:52 PM
DLynch updated the task description. (Show Details)

The action fields are using display:table-cell, which means they need a display:table parent. They did when first implemented, but that appears to have been lost during various refactors.

DLynch added a subscriber: DLynch.Jul 3 2018, 4:49 PM

Esanders: Looks like it was removed in 24fe991c00. ...though I can't see any evidence that the .oo-ui-actionFieldLayout-field class that's removed there would ever actually have been created by ActionFieldLayout. So.

Change 443659 had a related patch set uploaded (by DLynch; owner: DLynch):
[oojs/ui@master] ActionFieldLayout: parent of input/button needs display:table

https://gerrit.wikimedia.org/r/443659

Change 443667 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] ve.ui.MWTemplatePlaceholderPage: Avoid Firefox rendering issue

https://gerrit.wikimedia.org/r/443667

Since only one weird case is affected (ActionFieldLayout with align: 'left' and no label), I would rather work around this in VE (it makes no difference to use align: 'top' instead; I submitted a patch), and figure out what caused this new issue before we make changes (I think nothing relevant changes in our code, we should try to bisect, or it might be a Firefox bug).

Deskana assigned this task to matmarex.Jul 3 2018, 6:44 PM
Deskana triaged this task as Medium priority.
Deskana edited projects, added VisualEditor (Current work); removed VisualEditor.
Deskana moved this task from Incoming to Code review on the VisualEditor (Current work) board.

Change 443667 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] ve.ui.MWTemplatePlaceholderPage: Avoid Firefox rendering issue

https://gerrit.wikimedia.org/r/443667

Change 443659 abandoned by DLynch:
ActionFieldLayout: parent of input/button needs display:table

Reason:
Solved less generally in VE itself

https://gerrit.wikimedia.org/r/443659

Deskana closed this task as Resolved.Jul 12 2018, 2:37 PM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJul 12 2018, 2:37 PM