Page MenuHomePhabricator

Set the WMF cluster to use the new MCR-only schema
Closed, ResolvedPublic

Description

The following setting fully switches MediaWiki to the new, MCR enabled database schema for revision storage:

$wgMultiContentRevisionSchemaMigrationStage = SCHEMA_COMPAT_NEW;

This renders the following database fields unused:

  • revision.rev_text_id
  • revision.rev_content_model
  • revision.rev_content_format
  • archive.ar_text_id
  • archive.ar_content_model
  • archive.ar_content_format
WARNING: This marks the POINT OF NO RETURN for MCR deployment to the WMF cluster! Rolling this back would render all content of new revisions inaccessible!
WARNING: Because of cross-wiki revision access, this can only be done an ANY system on the cluster once ALL systems on the cluster write the new schema.

Details

Related Gerrit Patches:
operations/mediawiki-config : masterSet all sites to use the new MCR-only schema
operations/mediawiki-config : masterSet MCR migration stage to NEW on all wikis
operations/mediawiki-config : masterSet MCR migration stage to NEW on group 1
operations/mediawiki-config : masterSet MCR migration stage to NEW on group 0

Related Objects

Event Timeline

daniel triaged this task as Medium priority.Jun 27 2018, 11:34 AM
daniel created this task.
daniel renamed this task from Enable new MCR storage schemas on live systems to Set the WMF cluster to use the new MCR-only schema.Jul 1 2018, 12:21 PM
daniel updated the task description. (Show Details)Jul 2 2018, 2:41 PM
daniel updated the task description. (Show Details)Jul 8 2018, 8:17 PM
Nirmos added a subscriber: Nirmos.Feb 8 2019, 8:50 PM
greg added a project: Multimedia.Mar 7 2019, 10:59 PM
Restricted Application added a project: Multimedia. · View Herald TranscriptMar 15 2019, 5:59 PM
WDoranWMF moved this task from MCR to mop on the Core Platform Team board.Jul 26 2019, 6:39 PM

Change 549449 had a related patch set uploaded (by Daniel Kinzler; owner: Daniel Kinzler):
[operations/mediawiki-config@master] Set all sites to use the new MCR-only schema

https://gerrit.wikimedia.org/r/549449

Config patch scheduled to be deployed on November 12.

Change 549449 had a related patch set uploaded (by Krinkle; owner: Daniel Kinzler):
[operations/mediawiki-config@master] Set all sites to use the new MCR-only schema

https://gerrit.wikimedia.org/r/549449

Change 550534 had a related patch set uploaded (by Anomie; owner: Anomie):
[operations/mediawiki-config@master] Set MCR migration stage to NEW on group 0

https://gerrit.wikimedia.org/r/550534

Change 550534 merged by jenkins-bot:
[operations/mediawiki-config@master] Set MCR migration stage to NEW on group 0

https://gerrit.wikimedia.org/r/550534

Mentioned in SAL (#wikimedia-operations) [2019-11-12T19:41:33Z] <anomie@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Set MCR migration stage to NEW on group0 for T198312 (duration: 00m 52s)

T238288 is a duplicate of T237709, which is unrelated to this patch. This should not block deploying to group1.

Change 550844 had a related patch set uploaded (by Anomie; owner: Anomie):
[operations/mediawiki-config@master] Set MCR migration stage to NEW on group 1

https://gerrit.wikimedia.org/r/550844

Change 550844 merged by jenkins-bot:
[operations/mediawiki-config@master] Set MCR migration stage to NEW on group 1

https://gerrit.wikimedia.org/r/550844

Mentioned in SAL (#wikimedia-operations) [2019-11-14T14:48:43Z] <anomie@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Set MCR migration stage to NEW on group1 for T198312 (duration: 00m 53s)

T238288 is a duplicate of T237709, which is unrelated to this patch. This should not block deploying to group1.

Thanks, sorry about that

Thanks, sorry about that

No need to apologize, thanks for watching out for potential problems!

Change 551551 had a related patch set uploaded (by Anomie; owner: Anomie):
[operations/mediawiki-config@master] Set MCR migration stage to NEW on all wikis

https://gerrit.wikimedia.org/r/551551

Change 551551 merged by jenkins-bot:
[operations/mediawiki-config@master] Set MCR migration stage to NEW on all wikis

https://gerrit.wikimedia.org/r/551551

Mentioned in SAL (#wikimedia-operations) [2019-11-18T15:13:42Z] <anomie@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Set MCR migration stage to NEW on remaining wikis for T198312 (duration: 00m 53s)

Anomie closed this task as Resolved.Mon, Nov 18, 3:29 PM
Anomie claimed this task.
Anomie removed a project: Patch-For-Review.

Change 549449 abandoned by Anomie:
Set all sites to use the new MCR-only schema

Reason:
Forgot about this patch and did it as I259a71eb17141f4e245ba143265456d0b779de9a instead.

https://gerrit.wikimedia.org/r/549449