Page MenuHomePhabricator

Set a tag so that files imported with FileImporter can be filtered in Recent Changes
Closed, ResolvedPublic3 Story Points

Description

Acceptance Criteria

  • Set a tag so that files imported with FileImporter can be filtered in Recent Changes
  • Use the wording as described below

Wording
Labels according to https://en.wikipedia.org/wiki/Special:Tags:
Tag name: fileimporter
Appearance on change lists: imported with FileImporter
Description: File imported from another wiki, including file and page history.

Previous discussions
See https://commons.wikimedia.org/w/index.php?title=Commons:Village_pump&oldid=308275483, Section June 25, move files from a local wiki to Commons

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 27 2018, 12:45 PM
Lea_WMDE set the point value for this task to 3.Nov 28 2018, 4:57 PM
Lea_WMDE added a subscriber: Lea_WMDE.

We should tag all logs associated with the import null revision.

Pikne added a subscriber: Pikne.EditedNov 29 2018, 7:22 AM

If there's already going to be an import log entry then isn't the change tag kind of redundant?

Edit: I see, it may not be redundant depending on if import log enhancement comes with type of import that woud allow filtering file imports or not.

Concrete label to come as fast as possible

Concrete label to come as fast as possible

Labels according to https://en.wikipedia.org/wiki/Special:Tags:

Tag name: fileimporter
Appearance on change lists: imported with FileImporter
Description: File imported from another wiki, including file and page history.

Lea_WMDE triaged this task as Normal priority.Dec 6 2018, 10:13 AM
Lea_WMDE updated the task description. (Show Details)

Change 480093 had a related patch set uploaded (by Thiemo Kreuz (WMDE); owner: Thiemo Kreuz (WMDE)):
[mediawiki/extensions/FileImporter@master] [WIP] Add "fileimporter" tag

https://gerrit.wikimedia.org/r/480093

thiemowmde moved this task from Sprint Backlog to Doing on the WMDE-QWERTY-Sprint-2018-12-04 board.

I kind of gave up trying to write a nice automated test for this for various reasons. Instead, I did a manual test and confirmed the tag appears in all relevant situations:

Technically the tag is linked to the revision ID (for the page history and Special:Contributions), the log entry ID (for Special:Log), and a recent changes ID (relevant for – obviously – recent changes).

Change 480792 had a related patch set uploaded (by WMDE-Fisch; owner: WMDE-Fisch):
[mediawiki/extensions/FileImporter@master] Test to check for correctly added tags

https://gerrit.wikimedia.org/r/480792

Change 480093 merged by jenkins-bot:
[mediawiki/extensions/FileImporter@master] Add "fileimporter" tag to new import log entry and null revision

https://gerrit.wikimedia.org/r/480093

Change 480792 merged by jenkins-bot:
[mediawiki/extensions/FileImporter@master] Test to check for correctly added tags

https://gerrit.wikimedia.org/r/480792

Change 483119 had a related patch set uploaded (by WMDE-Fisch; owner: WMDE-Fisch):
[mediawiki/extensions/FileImporter@master] Add test for the upload log tag

https://gerrit.wikimedia.org/r/483119

Please note, that we just discovered an issue in core that blocks the creation for the upload log tag, there's a follow up task for that T213280

Currently some tags on the log entries can't be created due to T213280: Tags for different log entries on the same revision not working - https://gerrit.wikimedia.org/r/483119 includes a test that can validate if the entries are all created.

WMDE-Fisch closed this task as Resolved.Mar 26 2019, 2:08 PM

Let's close this for now since it's unclear if T213280 can be resolved soonish and everything else is tracked in there.