Page MenuHomePhabricator

PageTriage with AfC option: Options removed from NPP option are incorrectly saved when switching to AfC
Closed, ResolvedPublic3 Story Points

Description

Reproduce:

  1. Make sure Special:NewPagesFeed has AfC enabled
  2. In NPP mode, open the filters popup, remove all checkboxes; note: The 'Set filters' button is disabled
  3. Without clicking anything else or applying anything, click the "AfC" option to switch to AfC mode
  4. Switch back to NPP mode

Expected: The invalid options (the state where 'set filters' button was disabled) should have been ignored, and we should have the filters that were there before, or default filters.

Actual result: The filters are now on empty state, which is invalid, and NPP shows no articles at all.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Change 442980 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/extensions/PageTriage@master] Sanity-check NPP API filter values and add default

https://gerrit.wikimedia.org/r/442980

Mooeypoo claimed this task.Jun 28 2018, 8:50 PM

This probably isn't the best solution ever, sicne it will override previous values -- but it only happens if the user unclicked both checkboxes anyways, and it will only potentially override the specific unreviewed/reviewed checkbox state, so I think that's acceptable for a quickfix.

kaldari set the point value for this task to 3.Jul 3 2018, 11:24 PM

Change 442980 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@master] Sanity-check NPP API filter values and add default

https://gerrit.wikimedia.org/r/442980

Is there anything left to do for this?

Restricted Application added a project: Growth-Team. · View Herald TranscriptJul 9 2018, 3:26 AM

@MMiller_WMF this is ready to test; let me know if my reproduction explanation is lacking -- the title language is a little confusing.

Etonkovidova closed this task as Resolved.Jul 30 2018, 8:09 PM
Etonkovidova added a subscriber: Etonkovidova.

Checked in betalabs and testwiki (wmf.14) - the issue is fixed. If all checkboxes are un-checked with NPP option and then a user switches to AfC and back to NPP - the filters will revert to the last selected filters or to defaul.

MusikAnimal added a subscriber: MusikAnimal.

Thanks!