Page MenuHomePhabricator

After changes in my common.js, the changes are not loaded, need "?action=purge" on my common.js for reload
Closed, InvalidPublic

Description

Hello,

I made changes today in my common.js on frwiki.

I proceeded as usual, I save the changes, then I purge the cache of my browser (firefox on Linux) via Ctrl+Shift+R.

Despite this operation, the old javascript was still loaded.

I closed my browser, re-opened, and the old javascript was still loaded. I tried to do an "?action=purge" on my common.js.

At that moment, the new javascript was finally loaded.

I made another change and it was not loaded. As long as I do not do an "?action=purge" on my common.js, the old javascript is still loaded.

I do not know if this is a problem on my side, or if it concerns other people. In any case, this is the first time that it happens to me (I make regular changes on my common.js).

(sorry for my bad english)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 1 2018, 6:55 PM
Aklapper closed this task as Invalid.Jul 2 2018, 3:09 PM

Hi @Tractopelle-jaune. This sounds like a support request and expected behavior as both your web browser do caching and the Wikimedia servers too for performance reason. That is not a bug and that is why action=purge exists. For future reference, support requests can be asked on MediaWiki Support Desk. Thanks for your understanding!