Page MenuHomePhabricator

Archive the AzharAuth extension
Closed, ResolvedPublicRequest

Description

Reason:

@Dereckson wrote the AzharAuth MediaWiki extensions a few years ago. I would like to get it archived on the basis of:

@Dereckson confirmed the extension is no more used / developed: T198601#5940483

To-do list

  • This task
    • Add maintainers of that extension as subscribers to this task (if they have no apparent Phabricator account, notify them on-wiki or via email if possible and note it here).
    • Add Phabricator project <#ProjectX> as a tag for this task, or MediaWiki-extensions-Other if there is no project.
  • On-wiki documentation
    • Archive documentation on mediawiki.org (https://www.mediawiki.org/wiki/Extension:Azh%C3%A0r_Authentication): replace page contents with {{TNT|Archived extension|last revision id before archiving|reason=archive reasons, per [[phab:T######]]}}; include a link to this task in the reason parameter.
    • If documentation page was translatable, remove <translate>, visit Special:PageTranslation, and click "remove from translation" (if you don't have the translation administrator right, ask a user who does).
    • Archive Wikidata item associated with documentation page (https://www.wikidata.org/wiki/Q21676566) (remove nearly all statements, except instance of (P31) = MediaWiki extension (Q6805426), which should add a qualifier end time (P582) = the YYYY-MM-DD date that you decided to archive extension, generally per edit history, change English (and other languages if possible) description to "archived MediaWiki extension" (and its translation)).
  • Phabricator
    • Archive Phabricator project <#ProjectX> for the extension.
    • Mark all Phabricator tasks for the extension either Declined or Invalid.
    • Edit Phabricator project <#ProjectX> description for the extension with a link to this ticket.
  • Translatewiki.net/translations
    • Remove from translatewiki.net (groups/MediaWiki/mediawiki-extensions.txt) (add translatewiki.net project as a tag for this task).
  • Configuration/tests/integrations/etc.
  • Repositories

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 2 2018, 9:43 AM
MarcoAurelio changed the task status from Open to Stalled.Jul 2 2018, 9:54 AM
MarcoAurelio claimed this task.
MarcoAurelio triaged this task as Low priority.
MarcoAurelio added a subscriber: MarcoAurelio.

Yes, let's wait for @Dereckson.

Restricted Application added a project: User-MarcoAurelio. · View Herald TranscriptJul 2 2018, 9:54 AM
MarcoAurelio lowered the priority of this task from Low to Lowest.Jul 8 2018, 9:34 PM
Dereckson added a comment.EditedJul 22 2018, 10:27 PM

No objection, as long as there is an easy possibility to unarchive it.

Current status:

  • there is experimental code to upgrade the extension, written at the time anomie and tgr worked on the new AuthManager, but unpolished
  • there are 4 wikis with a need for an extension update, so yes, it should be done
  • it's not a current priority for this summer
  • it's also very probable a better migration path would be to use a more versatile SSO solution in front of both software

The un-archival, as it is the archival, is super easy; but if you or other people have plans to work on the extension in the near future I'd not bother archiving.

Dinoguy1000 updated the task description. (Show Details)Oct 16 2018, 7:05 PM
Dinoguy1000 added a project: translatewiki.net.

@Dereckson An update on the status of the extension or plans would be good if possible. Thanks.

Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptMar 13 2019, 12:17 PM

Considering that there has been no updates since T198601#4444237 and T198601#5020573, I'm leaning to start the archiving process. I'll wait a little bit again though.

We have pinged @Dereckson the primary author to check whether that extension is still in use and whether he is willing to migrate it to the MediaWiki 1.27 AuthManager framework.

wikiapiary shows now public deployment: https://wikiapiary.com/wiki/Extension:Azh%C3%A0r_Authentication

So I guess we should just archive it!

This extension isn't developed anymore. Yes, we can archive it.

hashar updated the task description. (Show Details)Mar 4 2020, 10:08 AM
Zoranzoki21 changed the task status from Stalled to Open.Mar 4 2020, 10:08 AM

This extension isn't developed anymore. Yes, we can archive it.

OK if so.

Change 602126 had a related patch set uploaded (by MarcoAurelio; owner: MarcoAurelio):
[mediawiki/extensions/AzharAuth@master] Archive extension

https://gerrit.wikimedia.org/r/602126

Change 602127 had a related patch set uploaded (by MarcoAurelio; owner: MarcoAurelio):
[translatewiki@master] Archive the AzharAuth extension

https://gerrit.wikimedia.org/r/602127

Change 602126 merged by MarcoAurelio:
[mediawiki/extensions/AzharAuth@master] Archive extension

https://gerrit.wikimedia.org/r/602126

Change 602129 had a related patch set uploaded (by MarcoAurelio; owner: MarcoAurelio):
[integration/config@master] [AzharAuth] Archive extension

https://gerrit.wikimedia.org/r/602129

Change 602132 had a related patch set uploaded (by MarcoAurelio; owner: MarcoAurelio):
[mediawiki/extensions@master] [AzharAuth] Archive extension

https://gerrit.wikimedia.org/r/602132

Change 602132 merged by MarcoAurelio:
[mediawiki/extensions@master] [AzharAuth] Archive extension

https://gerrit.wikimedia.org/r/602132

Change 602127 merged by jenkins-bot:
[translatewiki@master] Archive the AzharAuth extension

https://gerrit.wikimedia.org/r/602127

Mentioned in SAL (#wikimedia-releng) [2020-06-03T18:57:27Z] <hauskatze> GitHub: Mirror deleted: mediawiki-extensions-AzharAuth | refs. T198601

Change 602129 merged by jenkins-bot:
[integration/config@master] [AzharAuth] Archive extension

https://gerrit.wikimedia.org/r/602129

hashar updated the task description. (Show Details)Jun 3 2020, 8:33 PM
MarcoAurelio closed this task as Resolved.Jun 4 2020, 8:08 AM