Page MenuHomePhabricator

Template:Information not replaced on Commons
Closed, InvalidPublic

Description

From the talk page of the wish on deWP:

When I try to export this file https://de.wikipedia.org/wiki/Datei:Ebrach_Prospekt_Ep-Orgel.JPG from dewiki to Commons, the information template (or it's parameters) isn't matched:

{{Information
|Beschreibung     = Prospekt der Epistelorgel der ehem. Abteikirche Ebrach
|Quelle           = eigenes Foto
|Urheber          = Metzner
|Datum            = 20. 10. 2012
|Genehmigung      = ja
|Andere Versionen = 
|Anmerkungen      = 
}}

Even through the Config-Page contains:

;Information:Information|@Description=Beschreibung|@Source=Quelle|Author=Urheber|Date=Datum|Permission=Genehmigung|other_versions=Andere Versionen

Its parameters remain in German, leading to an error on the import preview page:

Event Timeline

Restricted Application added a project: TCB-Team. · View Herald TranscriptJul 2 2018, 11:16 AM

Note: I could reproduce this with several other files (in deed all files on dewiki I tried).

thiemowmde closed this task as Invalid.Jul 2 2018, 11:58 AM
thiemowmde added a subscriber: thiemowmde.

The reason for this is that Wikimedia Commons is still using an outdated version of the FileImporter extension. According to http://commons.wikimedia.org/wiki/Special:Version the version if still from June 26. This version was not able to do anything with template parameters, only template names.

This should resolve itself with the next train. The next I see on https://wikitech.wikimedia.org/wiki/Deployments is planned for July 10.