Page MenuHomePhabricator

Pagebanner positioning doesn't work on RTL wikis
Closed, ResolvedPublic

Description

Please fix Pagebanner on mobile site in Pashto Wikivoyage. Pashto Wikivoyage shows just half of the picture in banner, but it's just when we have any Arabic language in setting for example Pashto or Persian
For Example: Pagebanner when we display language to Pashto


But when we display language to English or Norwegian it shows everything alright on the same site.
Just like this:

thank you so much.

Acceptance criteria

https://ps.wikivoyage.org/wiki/%D9%82%D8%A8%D8%B1%D8%B3?uselang=en should show the same banner as https://ps.wikivoyage.org/wiki/%D9%82%D8%A8%D8%B1%D8%B3?uselang=ps

Developer notes

The positioning assumes a LTR image.
In a RTL wiki a RTL right image will clip from the left rather than from the right.
Switching the direction of the banner element resolves this

Event Timeline

Af420 created this task.Jul 4 2018, 9:13 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 4 2018, 9:13 PM
Af420 updated the task description. (Show Details)Jul 4 2018, 9:28 PM
Restricted Application added subscribers: jeblad, jhsoby. · View Herald TranscriptJul 4 2018, 9:28 PM
Aklapper changed the task status from Open to Stalled.Jul 4 2018, 10:23 PM

Hi @Baloch007, thanks for taking the time to report this!
Unfortunately this report lacks some information. If you have time and can still reproduce the problem: Please add a more complete description to this report.
That can be a clear list of specific steps to reproduce the situation, providing a link to the website in the screenshots where the issue can be seen.
You can edit the task description by clicking Edit Task.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. Thanks!

Jdlrobson added a subscriber: Jdlrobson.

This looks like a right-to-left issue, but we'll need to know the image in question to fix.
At very least, I need to know the URL and image you used for the banner as since I am not familiar with the Pashto language I can't read the title in the banner.

The code in the wikipage should look something like this:

{{PAGEBANNER:Grand_canyon.jpg}}

It looks like Pashto is not using WikidataPageBanner as evidenced by the 2 titles on https://ps.wikivoyage.org/wiki/%D9%82%D8%A8%D8%B1%D8%B3 so much more context needed before we can look at this!

Looking forward to your reply!

Restricted Application added a project: I18n. · View Herald TranscriptJul 10 2018, 9:16 PM
Af420 added a comment.Jul 11 2018, 9:53 AM

This looks like a right-to-left issue, but we'll need to know the image in question to fix.
At very least, I need to know the URL and image you used for the banner as since I am not familiar with the Pashto language I can't read the title in the banner.

The code in the wikipage should look something like this:

{{PAGEBANNER:Grand_canyon.jpg}}

It looks like Pashto is not using WikidataPageBanner as evidenced by the 2 titles on https://ps.wikivoyage.org/wiki/%D9%82%D8%A8%D8%B1%D8%B3 so much more context needed before we can look at this!

Looking forward to your reply!

@Herald have a look at the same link now: https://ps.wikivoyage.org/wiki/%D9%82%D8%A8%D8%B1%D8%B3 :-)

Jdlrobson renamed this task from Please fix Pagebanner on PsWikivoyage to Pagebanner positioning doesn't work on RTL wikis.Jul 11 2018, 7:04 PM
Jdlrobson changed the task status from Stalled to Open.
Jdlrobson updated the task description. (Show Details)
Restricted Application added a project: Wikidata. · View Herald TranscriptJul 11 2018, 7:05 PM

Change 445239 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/WikidataPageBanner@master] Use margin-right rather than margin-left on RTL wikis

https://gerrit.wikimedia.org/r/445239

Jdlrobson updated the task description. (Show Details)

Change 445239 merged by jenkins-bot:
[mediawiki/extensions/WikidataPageBanner@master] Banners should display same in RTL or LTR

https://gerrit.wikimedia.org/r/445239

Af420 added a comment.Jul 12 2018, 9:22 AM

Yes it's correct :-)

@Jdlrobson Yes it's correct :-)

Jdlrobson closed this task as Resolved.Jul 12 2018, 2:18 PM
Jdlrobson claimed this task.

Thanks for confirming! This will be deployed in 1.32.wmf.13 currently planned for July 17th (https://wikitech.wikimedia.org/wiki/Deployments)

Restricted Application changed the subtype of this task from "Deadline" to "Task". · View Herald TranscriptAug 23 2018, 12:00 AM