Page MenuHomePhabricator

LinkedWiki extension requires php 7.1 due to bordercloud/sparql
Closed, ResolvedPublic

Description

The LinkedWiki extension depends on bordercloud/sparql. Its composer file requires php 7.1+ ( https://github.com/BorderCloud/SPARQL/issues/5 ).

Since Wikimedia CI only supports php 7.0 for now, we can't run tests from Jenkins:

+ composer install --ansi --no-progress --prefer-dist --profile -v
Loading composer repositories with package information
Updating dependencies (including require-dev)
Dependency resolution completed in 0.012 seconds
Your requirements could not be resolved to an installable set of packages.

Problem 1
   - Installation request for bordercloud/sparql dev-master -> satisfiable by bordercloud/sparql[dev-master].
   - bordercloud/sparql dev-master requires php >=7.1 -> your PHP version (7.0.30) does not satisfy that requirement.

Filled Upstream as https://github.com/BorderCloud/SPARQL/issues/6

Event Timeline

hashar created this task.Jul 5 2018, 4:18 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 5 2018, 4:18 PM
Karima added a comment.Jul 5 2018, 5:38 PM

@hashar
You can re-try. Bye

hashar closed this task as Resolved.Jul 7 2018, 9:03 PM
hashar assigned this task to Karima.

Thank you!