Page MenuHomePhabricator

Show imported files / file pages in users' special pages in target wiki
Closed, ResolvedPublic5 Story Points

Description

Motivation
When a file is moved, its uploaders should still receive full credit for their actions. Since the moved file may be deleted in the source wiki, it is of vital importance that you can see the edits on the target wiki.

Example:

Acceptance Criteria

  • The edits on moved file pages appear in the Special:Contributions file
  • The moved files appear in the Special:ListFiles file
  • This should happen both for users that already existed on Commons before the move, and newly created users.

Notes
This ticket should be handled after T209346: If a user's file was moved to Commons, their account should be autocreated

Event Timeline

thiemowmde triaged this task as High priority.Jul 9 2018, 1:29 PM
thiemowmde created this task.
thiemowmde moved this task from Incoming to Move files to Commons on the TCB-Team board.
Lea_WMDE updated the task description. (Show Details)Nov 13 2018, 1:11 PM
Lea_WMDE renamed this task from Link log entries, page creations, and edits to the users CentralAuth account to Show imported files / file pages in users' special pages in target wiki.Nov 13 2018, 2:21 PM
Lea_WMDE updated the task description. (Show Details)
Lea_WMDE set the point value for this task to 5.
Pikne added a subscriber: Pikne.Nov 14 2018, 8:04 AM

This particular file (Modarres Expressway, Tehran 20110912.JPG) doesn't appear in Special:ListFiles because "Include old versions of files" is unchecked.

thiemowmde updated the task description. (Show Details)Nov 14 2018, 8:32 AM

That solves a relevant part of this ticket. Thanks a lot for the hint!

WMDE-Fisch moved this task from Sprint Backlog to Doing on the WMDE-QWERTY-Sprint-2018-11-20 board.

As soon as https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/FileImporter/+/474952/ is merged and on beta the state of this could be tested extensively.

Beta seems to have some DB problems at the moment but to get a sneak peak here, I tested the behavior on my local "wiki-farm" and it seems that the issue is fixed with https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/FileImporter/+/474952/ . By using CentralAuth to retrieved/create local users and associating the uploads to these the contributions seem fine.

From my perspective this is done/fixed now.

Lea_WMDE closed this task as Resolved.Dec 3 2018, 10:49 AM
Lea_WMDE moved this task from Demo to Done on the WMDE-QWERTY-Sprint-2018-11-20 board.