Page MenuHomePhabricator

After publishing content translation target wiki should not show as missing when publishing on Simple English
Closed, ResolvedPublic

Description

I just translated a page, and "published" it, and the target language (I translated to) shows as missing. The target language must never show as missing. Also compare screenshot.

Event Timeline

Eptalon created this task.Jul 9 2018, 9:18 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 9 2018, 9:18 PM
Pginer-WMF triaged this task as Medium priority.Jul 11 2018, 1:24 PM
Pginer-WMF moved this task from Needs Triage to Bugs on the ContentTranslation board.
Pginer-WMF added a subscriber: Pginer-WMF.

Content Translation shows grey interlanguage links when an article is missing in a language the user can create a translation for. Once the translation has been published, the grey interlanguage link should not be shown since it is confusing to flag the current article as missing. There are some aspects to investigate here:

  • Why the grey link is shown despite the article already existing.
  • Why the grey link for "Simple English" is shown in Simple English Wikipedia. Links to invite users to translate are expected to shown languages that are different from the one in the current wiki.
  • We may want to check if this issue is specific to Simple English or happens for other wikis.

This issue is probably not related to the content Translation tool, but perhaps to the mechanism interwiki links are calculated.
Also compare the image below, to find a case where a page has been newly created on SEWP, and Interwiki links were later added.

No matter what is done: The interlanguage link for the wiki I am editing in should not be shown (either as missing or present, in any case).

Arrbee moved this task from Bugs to Check & Move on the ContentTranslation board.Jul 22 2019, 1:55 PM
Arrbee added subscribers: Jpita, Arrbee.

If @Jpita finds a clear way to reproduce this error, we will try to trace and send it to the best project it fits.

Steps:

  1. open article with missing translations
  2. click grey link for a missing article
  3. translate and publish the article
  4. open the new article page
  5. open the original article page in another tab
  • The grey link shows correctly for the new page but not for the original one
  • If we open the original page and add ?action=purge to the url, it shows the correct grey link after the purge

@Pginer-WMF is there any action we can do here?
maybe we can force the purge after a translation is finished, should be very straightforward.

@Pginer-WMF is there any action we can do here?
maybe we can force the purge after a translation is finished, should be very straightforward.

If this is technically feasible it seems a good solution.
The problem seems to happen with enough frequency and for users noticing it creates confusion and may make them do additional unnecessary work trying to connect the page on Wikidata manually.

When article is published with Content Translation, we automatically connect to Wikidata item and do the purging, so that interlanguage links are updated.
That makes sense for newly created article. I don't think we should purge cache for articles in all other languages.

However, there is a different problem described in this task. Article was published to Simple English Wikipedia (which means it was target wiki and page got purged), but gray interlanguage link still shows Simple English as option. We have seen numerous problems around Simple English wiki and this is one of them.

I checked and the problem is still there. If Simple English is one of the languages determined (by the algorithm) to be one of user's preferred languages, it will be suggested to translate into, even on Simple English Wikipedia.

When article is published with Content Translation, we automatically connect to Wikidata item and do the purging, so that interlanguage links are updated.
That makes sense for newly created article. I don't think we should purge cache for articles in all other languages.

Are we doing the purging on the target article or also on the source one?
It does not make sense to purge many articles, but I expect that the one in the source language may be the one more likely to create confusion. Does it make sense to purge that if we are not doing it already?

However, there is a different problem described in this task. Article was published to Simple English Wikipedia (which means it was target wiki and page got purged), but gray interlanguage link still shows Simple English as option. We have seen numerous problems around Simple English wiki and this is one of them.

Ok. Let's keep this ticket scope focused on the Simple English issue (I'll make it explicit in the title), and decide about whether a new ticket is needed based on the question above.

Pginer-WMF renamed this task from After publishing content translation target wiki should not show as missing to After publishing content translation target wiki should not show as missing when publishing on Simple English.Jul 24 2019, 9:19 AM

I translated 2 different articles from english to simple english and simple english to spanish and saw no issues.

Are we doing the purging on the target article or also on the source one?
It does not make sense to purge many articles, but I expect that the one in the source language may be the one more likely to create confusion. Does it make sense to purge that if we are not doing it already?

We only purge newly published article (target article). That is achieved with one API call using action='purge', and it should be easy to do for source article as well.

I translated 2 different articles from english to simple english and simple english to spanish and saw no issues.

Great. I'll close the ticket, then.

We only purge newly published article (target article). That is achieved with one API call using action='purge', and it should be easy to do for source article as well.

I created a ticket capturing the idea. Not for immediate attention, but we can consider the idea if we observe more frequent issues like this: T228893: Purge source article after publishing a translation to ensure the update of interlanguage links

Pginer-WMF closed this task as Resolved.Jul 24 2019, 3:42 PM
Pginer-WMF claimed this task.