Page MenuHomePhabricator

Define textfield
Closed, DuplicatePublic

Description

(I'm sorry if this task does not fit but I've just started using Phabricator.)

I'm seeing the feature Page preview more and more often. As I use Wikipedia for math and physics, too, I'm often interested in having, e.g. a definition in the page preview. That's why I thought it would be a nice feature if it was possible to define on a Wikipedia-page what text should come into the page preview. Maybe this can be automated by looking at different categories (physics, philosophy, ...) and looking at what there is generally wanted in the preview.

Greetings,

Event Timeline

Famfop created this task.Jul 10 2018, 11:00 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 10 2018, 11:00 AM

Hi @Famfop, thanks for taking the time to report this!

Do you have specific examples (links to pages) when and why the current (default) page preview is not sufficient?

Jdlrobson closed this task as a duplicate of T107199: Let users specify TextExtract.EditedJul 10 2018, 3:33 PM
Jdlrobson added a subscriber: Jdlrobson.

Thanks for the report @Famfop I've merged this into T169346 which I think asks for the same thing you are asking for. Let me know if I've misunderstood and I'll reopen and rephrase. Thanks for taking the time to start using Phabricator!

I've read a bit about the other task but I'm not sure if I am understanding it correctly.
Firstly, about my understanding of page previews (correct me if I'm wrong) (very simplified): Page preview wraps the introductory text of the linked wikipedia article.
Now, let me give an example of how I'd like it to behave:
I'm reading the wikipedia article about Energy and I am reading this part about Classical mechanics. Now read the sentence:

Work, a function of energy, is force times distance.

Ok, the example is a bit stupid because the formula defining work is given below, but when I hover over the link "Work", I read the general introduction text of the Work-Wikipedia-article. But I guess in many cases I am really interested in seeing the defining formula with the integral over F*ds.

Of course this example would be even more appropriate in a math-article (I couldn't find a good example so fast xD) but basically what I want to say is that you should be able to define inside a wikipedia article, what should be displayed in a page preview when hovering over the link on another page.

The link can only ever show a summary of the content it links to
In this particular case the link might be edited to point to a section in the Work_(physics) section.
e.g
https://en.wikipedia.org/wiki/Work_(physics)#Work_and_energy
or the wikitext

[[Work (physics)#Work_and_energy|work]]

T156041 is open about pulling summaries from sections. I think this would solve the particular problem you are describing.