Page MenuHomePhabricator

SpamBlacklist / MemcachedBagOStuff.php: Key contains invalid characters error prevents pages from being saved on many Wikipedias
Closed, ResolvedPublic

Description

2018-07-10 11:33:46 [W0SZmgpAAD4AAFHXWLcAAACR] mw1267 commonswiki 1.32.0-wmf.10 exception ERROR: [W0SZmgpAAD4AAFHXWLcAAACR] /w/index.php?title=File:ColognePride_2018-Samstag-Hauptb%C3%BChne-1750-Lukas_Rieger-7838.jpg&action=submit   Exception from line 156 of /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/MemcachedBagOStuff.php: Key contains invalid characters: commonswiki:blacklist:spam:pass:de6f3658380a0d67308e2c1469aa8c17ed424b1a:File%3AColognePride_2018-Samstag-Hauptbühne-1750-Lukas_Rieger-7838.jpg {"exception_id":"W0SZmgpAAD4AAFHXWLcAAACR","exception_url":"/w/index.php?title=File:ColognePride_2018-Samstag-Hauptb%C3%BChne-1750-Lukas_Rieger-7838.jpg&action=submit","caught_by":"mwe_handler"} 
[Exception Exception] (/srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/MemcachedBagOStuff.php:156) Key contains invalid characters: commonswiki:blacklist:spam:pass:de6f3658380a0d67308e2c1469aa8c17ed424b1a:File%3AColognePride_2018-Samstag-Hauptbühne-1750-Lukas_Rieger-7838.jpg
  #0 /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/MemcachedPeclBagOStuff.php(154): MemcachedBagOStuff->validateKeyEncoding(string)
  #1 /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/MemcachedBagOStuff.php(56): MemcachedPeclBagOStuff->getWithToken(string, NULL, integer)
  #2 /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/BagOStuff.php(197): MemcachedBagOStuff->doGet(string, integer)
  #3 /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/ReplicatedBagOStuff.php(80): BagOStuff->get(string, integer)
  #4 /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/BagOStuff.php(197): ReplicatedBagOStuff->doGet(string, integer)
  #5 /srv/mediawiki/php-1.32.0-wmf.10/extensions/SpamBlacklist/includes/SpamBlacklist.php(78): BagOStuff->get(string)
  #6 /srv/mediawiki/php-1.32.0-wmf.10/extensions/SpamBlacklist/includes/SpamBlacklistHooks.php(42): SpamBlacklist->filter(array, Title)
  #7 /srv/mediawiki/php-1.32.0-wmf.10/includes/Hooks.php(174): SpamBlacklistHooks::filterMergedContent(RequestContext, WikitextContent, Status, string, User, boolean)
  #8 /srv/mediawiki/php-1.32.0-wmf.10/includes/Hooks.php(202): Hooks::callHook(string, array, array, NULL)
  #9 /srv/mediawiki/php-1.32.0-wmf.10/includes/EditPage.php(1702): Hooks::run(string, array)
  #10 /srv/mediawiki/php-1.32.0-wmf.10/includes/EditPage.php(2146): EditPage->runPostMergeFilters(WikitextContent, Status, User)
  #11 /srv/mediawiki/php-1.32.0-wmf.10/includes/EditPage.php(1529): EditPage->internalAttemptSave(NULL, boolean)
  #12 /srv/mediawiki/php-1.32.0-wmf.10/includes/EditPage.php(662): EditPage->attemptSave(NULL)
  #13 /srv/mediawiki/php-1.32.0-wmf.10/includes/actions/EditAction.php(60): EditPage->edit()
  #14 /srv/mediawiki/php-1.32.0-wmf.10/includes/actions/SubmitAction.php(38): EditAction->show()
  #15 /srv/mediawiki/php-1.32.0-wmf.10/includes/MediaWiki.php(500): SubmitAction->show()
  #16 /srv/mediawiki/php-1.32.0-wmf.10/includes/MediaWiki.php(294): MediaWiki->performAction(ImagePage, Title)
  #17 /srv/mediawiki/php-1.32.0-wmf.10/includes/MediaWiki.php(867): MediaWiki->performRequest()
  #18 /srv/mediawiki/php-1.32.0-wmf.10/includes/MediaWiki.php(524): MediaWiki->main()
  #19 /srv/mediawiki/php-1.32.0-wmf.10/index.php(42): MediaWiki->run()
  #20 /srv/mediawiki/w/index.php(3): include(string)
  #21 {main}

Event Timeline

Restricted Application added subscribers: Cosine02, Aklapper. · View Herald TranscriptJul 10 2018, 11:51 AM
Wong128hk updated the task description. (Show Details)Jul 10 2018, 11:52 AM

Same happened with 可丽饼, 慢性疲勞症候群. Problem reported and confirmed by multiple editors.

aaron added a subscriber: aaron.Jul 10 2018, 11:53 AM
Key contains invalid characters: zhwiki:blacklist:spam:pass:593a98fd45a6bef5b16ab648bf2eea6368883524:人類疱疹病毒第四型
#0 /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/MemcachedPeclBagOStuff.php(154): MemcachedBagOStuff->validateKeyEncoding(string)
#1 /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/MemcachedBagOStuff.php(56): MemcachedPeclBagOStuff->getWithToken(string, NULL, integer)
#2 /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/BagOStuff.php(197): MemcachedBagOStuff->doGet(string, integer)
#3 /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/ReplicatedBagOStuff.php(80): BagOStuff->get(string, integer)
#4 /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/BagOStuff.php(197): ReplicatedBagOStuff->doGet(string, integer)
#5 /srv/mediawiki/php-1.32.0-wmf.10/extensions/SpamBlacklist/includes/SpamBlacklist.php(78): BagOStuff->get(string)
#6 /srv/mediawiki/php-1.32.0-wmf.10/extensions/SpamBlacklist/includes/SpamBlacklist.php(293): SpamBlacklist->filter(array, Title, boolean, string)
#7 /srv/mediawiki/php-1.32.0-wmf.10/extensions/SpamBlacklist/includes/SpamBlacklistHooks.php(67): SpamBlacklist->warmCachesForFilter(Title, array)
#8 /srv/mediawiki/php-1.32.0-wmf.10/includes/Hooks.php(174): SpamBlacklistHooks::onParserOutputStashForEdit(WikiPage, WikitextContent, ParserOutput, string, User)
#9 /srv/mediawiki/php-1.32.0-wmf.10/includes/Hooks.php(202): Hooks::callHook(string, array, array, NULL)
#10 /srv/mediawiki/php-1.32.0-wmf.10/includes/api/ApiStashEdit.php(215): Hooks::run(string, array)
#11 /srv/mediawiki/php-1.32.0-wmf.10/includes/api/ApiStashEdit.php(151): ApiStashEdit::parseAndStash(WikiPage, WikitextContent, User, string)
#12 /srv/mediawiki/php-1.32.0-wmf.10/includes/api/ApiMain.php(1584): ApiStashEdit->execute()
#13 /srv/mediawiki/php-1.32.0-wmf.10/includes/api/ApiMain.php(535): ApiMain->executeAction()
#14 /srv/mediawiki/php-1.32.0-wmf.10/includes/api/ApiMain.php(506): ApiMain->executeActionWithErrorHandling()
#15 /srv/mediawiki/php-1.32.0-wmf.10/api.php(83): ApiMain->execute()
#16 /srv/mediawiki/w/api.php(3): include(string)
#17 {main}
Reedy renamed this task from "fatal exception" reported while editing "人類疱疹病毒第四型" at zh.wikipedia to MemcachedBagOStuff.php: Key contains invalid characters.Jul 10 2018, 11:53 AM
Reedy triaged this task as High priority.
Reedy updated the task description. (Show Details)

Error Message: [W0SeTwpAME0AACnkQvwAAABE] 2018-07-10 11:53:52: 类型“Exception”的致命例外

NickK raised the priority of this task from High to Unbreak Now!.Jul 10 2018, 11:54 AM
NickK added a subscriber: NickK.

Same for me.

I obtain the following error message while editing several pages (different pages) in Ukrainian Wikipedia:
[W0SdsgpAICwAAC85A3IAAAAF] 2018-07-10 11:51:15: Fatal exception of type "Exception"
[W0SeYgpAMEsAAHuX5m0AAAAJ] 2018-07-10 11:54:11: Fatal exception of type "Exception"
etc.

I do manage to create redirects, but there is no way I can edit existing pages. No edits are saved.

Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptJul 10 2018, 11:54 AM

A fix is in progress

I see this might be an encoding problem, so:
Pages I could not edit are [[:w:uk:Груповий етап Ліги чемпіонів УЄФА 2011—2012]], [[:w:uk:Обговорення Вікіпедії:Заявки на позбавлення прав адміністратора]] and others (edits not saved).
I could edit the page [[:w:uk:Under the Ladder]] (edit saved correctly).
Looks like editing any page with non-Latin name is impossible now.

Roy17 added a subscriber: Roy17.Jul 10 2018, 12:04 PM

Quite triky issues found.
See [[:zh-yue:Wikipedia:沙盤]]. Reverting an edit was not possible unless the comment was not given.
I tried editing on another page, leaving comments blank, yet the following error code was shown to me.
[W0SfbQpAAD8AAHG-ndUAAAAY] 2018-07-10 11:58:38: 嚴重例外類型「Exception」

Roy17 removed a subscriber: Roy17.Jul 10 2018, 12:07 PM

Problems fixed for the originally reported page. Thanks for the quick response!

Same problem here.

Reedy lowered the priority of this task from Unbreak Now! to High.Jul 10 2018, 12:27 PM
deryckchan renamed this task from MemcachedBagOStuff.php: Key contains invalid characters to SpamBlacklist / MemcachedBagOStuff.php: Key contains invalid characters error prevents pages from being saved on many Wikipedias.Jul 10 2018, 12:27 PM
deryckchan raised the priority of this task from High to Unbreak Now!.
deryckchan lowered the priority of this task from Unbreak Now! to High.

Same problem here.

That looks to be ~40 minutes ago, so should be fixed now

aaron closed this task as Resolved.Jul 10 2018, 12:42 PM

The configuration change was reverted. It will be fine to re-apply it once 4ad6b70ba132c66e14a706eae240887885946a42 is merged (I thought that 13 day old change landed already).

That looks to be ~40 minutes ago, so should be fixed now

Yes I can edit that page now. Thanks. Actually what happened?