Page MenuHomePhabricator

MemcachedBagOStuff.php: Key contains invalid characters
Closed, ResolvedPublic

Description

2018-07-09 22:12:12 [W0PdugpAAD4AACjgbZ8AAAAF] mw1267 mediawikiwiki 1.32.0-wmf.10 exception ERROR: [W0PdugpAAD4AACjgbZ8AAAAF] /wiki/Help:Magic_words/es   Exception from line 156 of /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/MemcachedBagOStuff.php: Key contains invalid characters: WANCache:v:mediawikiwiki:messages:código_de_idioma_del_objetivo:hash:v1 {"exception_id":"W0PdugpAAD4AACjgbZ8AAAAF","exception_url":"/wiki/Help:Magic_words/es","caught_by":"mwe_handler"} 
[Exception Exception] (/srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/MemcachedBagOStuff.php:156) Key contains invalid characters: WANCache:v:mediawikiwiki:messages:código_de_idioma_del_objetivo:hash:v1
  #0 /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/MemcachedPeclBagOStuff.php(245): MemcachedBagOStuff->validateKeyEncoding(string)
  #1 /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/ReplicatedBagOStuff.php(86): MemcachedPeclBagOStuff->getMulti(array, integer)
  #2 /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/WANObjectCache.php(357): ReplicatedBagOStuff->getMulti(array)
  #3 /srv/mediawiki/php-1.32.0-wmf.10/includes/libs/objectcache/WANObjectCache.php(302): WANObjectCache->getMulti(array, array, array, array)
  #4 /srv/mediawiki/php-1.32.0-wmf.10/includes/cache/MessageCache.php(694): WANObjectCache->get(string, NULL, array)
  #5 /srv/mediawiki/php-1.32.0-wmf.10/includes/cache/MessageCache.php(281): MessageCache->getValidationHash(string)
  #6 /srv/mediawiki/php-1.32.0-wmf.10/includes/cache/MessageCache.php(972): MessageCache->load(string)
  #7 /srv/mediawiki/php-1.32.0-wmf.10/includes/cache/MessageCache.php(902): MessageCache->getMsgFromNamespace(string, string)
  #8 /srv/mediawiki/php-1.32.0-wmf.10/includes/cache/MessageCache.php(869): MessageCache->getMessageForLang(Language, string, boolean, array)
  #9 /srv/mediawiki/php-1.32.0-wmf.10/includes/cache/MessageCache.php(810): MessageCache->getMessageFromFallbackChain(Language, string, boolean)
  #10 /srv/mediawiki/php-1.32.0-wmf.10/includes/Message.php(1296): MessageCache->get(string, boolean, Language)
  #11 /srv/mediawiki/php-1.32.0-wmf.10/includes/Message.php(848): Message->fetchMessage()
  #12 /srv/mediawiki/php-1.32.0-wmf.10/includes/Message.php(952): Message->toString(string)
  #13 /srv/mediawiki/php-1.32.0-wmf.10/extensions/Translate/TranslateHooks.php(472): Message->plain()
  #14 /srv/mediawiki/php-1.32.0-wmf.10/includes/Hooks.php(174): TranslateHooks::translateMessageDocumentationLanguage(array, string)
  #15 /srv/mediawiki/php-1.32.0-wmf.10/includes/Hooks.php(202): Hooks::callHook(string, array, array, NULL)
  #16 /srv/mediawiki/php-1.32.0-wmf.10/languages/Language.php(838): Hooks::run(string, array)
  #17 /srv/mediawiki/php-1.32.0-wmf.10/languages/Language.php(810): Language::fetchLanguageNamesUncached(string, string)
  #18 /srv/mediawiki/php-1.32.0-wmf.10/languages/Language.php(896): Language::fetchLanguageNames(string, string)
  #19 /srv/mediawiki/php-1.32.0-wmf.10/includes/parser/CoreParserFunctions.php(877): Language::fetchLanguageName(string, string)
  #20 /srv/mediawiki/php-1.32.0-wmf.10/includes/parser/Parser.php(3434): CoreParserFunctions::language(Parser, string, string)
  #21 /srv/mediawiki/php-1.32.0-wmf.10/includes/parser/Parser.php(3138): Parser->callParserFunction(PPFrame_Hash, string, array)
  #22 /srv/mediawiki/php-1.32.0-wmf.10/includes/parser/Preprocessor_Hash.php(1114): Parser->braceSubstitution(array, PPFrame_Hash)
  #23 /srv/mediawiki/php-1.32.0-wmf.10/includes/parser/Parser.php(2953): PPFrame_Hash->expand(PPNode_Hash_Tree, integer)
  #24 /srv/mediawiki/php-1.32.0-wmf.10/includes/parser/Parser.php(1297): Parser->replaceVariables(string)
  #25 /srv/mediawiki/php-1.32.0-wmf.10/includes/parser/Parser.php(446): Parser->internalParse(string)
  #26 /srv/mediawiki/php-1.32.0-wmf.10/includes/content/WikitextContent.php(323): Parser->parse(string, Title, ParserOptions, boolean, boolean, integer)
  #27 /srv/mediawiki/php-1.32.0-wmf.10/includes/content/AbstractContent.php(516): WikitextContent->fillParserOutput(Title, integer, ParserOptions, boolean, ParserOutput)
  #28 /srv/mediawiki/php-1.32.0-wmf.10/includes/poolcounter/PoolWorkArticleView.php(145): AbstractContent->getParserOutput(Title, integer, ParserOptions)
  #29 /srv/mediawiki/php-1.32.0-wmf.10/includes/poolcounter/PoolCounterWork.php(123): PoolWorkArticleView->doWork()
  #30 /srv/mediawiki/php-1.32.0-wmf.10/includes/page/Article.php(604): PoolCounterWork->execute()
  #31 /srv/mediawiki/php-1.32.0-wmf.10/includes/actions/ViewAction.php(68): Article->view()
  #32 /srv/mediawiki/php-1.32.0-wmf.10/includes/MediaWiki.php(500): ViewAction->show()
  #33 /srv/mediawiki/php-1.32.0-wmf.10/includes/MediaWiki.php(294): MediaWiki->performAction(Article, Title)
  #34 /srv/mediawiki/php-1.32.0-wmf.10/includes/MediaWiki.php(867): MediaWiki->performRequest()
  #35 /srv/mediawiki/php-1.32.0-wmf.10/includes/MediaWiki.php(524): MediaWiki->main()
  #36 /srv/mediawiki/php-1.32.0-wmf.10/index.php(42): MediaWiki->run()
  #37 /srv/mediawiki/w/index.php(3): include(string)
  #38 {main}

Event Timeline

Reedy created this task.Jul 10 2018, 12:06 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 10 2018, 12:06 PM
Reedy reopened this task as Open.Jul 10 2018, 12:24 PM
Reedy added a subscriber: Stryn.

@Stryn It's not the same bug; this is caused by MW core, not SpamBlacklist

Oh sorry, apologize!
I thought they had exactly the same title and description.

aaron closed this task as Resolved.Jul 11 2018, 10:07 AM
aaron claimed this task.
aaron added a subscriber: aaron.

This was fixed by the 61a7e1acd0af4a5386df03335733accfde179fa1 backport.