Page MenuHomePhabricator

Remove LanguageGetMagic and LanguageGetSpecialPageAliases hooks (deprecated in 1.16) from MW Core
Closed, ResolvedPublic

Description

1.16? Seriously. DIE

Event Timeline

Reedy created this task.Jul 11 2018, 1:27 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 11 2018, 1:27 AM

Change 445058 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@master] Remove LanguageGetMagic hook

https://gerrit.wikimedia.org/r/445058

Change 445058 abandoned by Legoktm:
Remove LanguageGetMagic hook

Reason:
Duplicate of Change-Id: Idcaf1b2c24c64653f700be4fe810ed124ba4ab7c

https://gerrit.wikimedia.org/r/445058

Change 439793 had a related patch set uploaded (by Legoktm; owner: Jforrester):
[mediawiki/core@master] Drop the LanguageGetSpecialPageAliases and LanguageGetMagic hooks

https://gerrit.wikimedia.org/r/439793

Legoktm added a subscriber: Legoktm.

This needs to wait until 1.32 to follow the deprecation policy since it was only hard deprecated in 1.31.

Err, hard deprecated in 1.32, will be removed in 1.33.

Jdforrester-WMF renamed this task from Remove LanguageGetMagic (deprecated in 1.16) from MW Core to Remove LanguageGetMagic and LanguageGetSpecialPageAliases hooks (deprecated in 1.16) from MW Core.Jul 11 2018, 6:32 PM
Jdforrester-WMF changed the task status from Open to Stalled.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Marking as stalled then.

Jdforrester-WMF closed this task as Resolved.Oct 30 2018, 5:58 PM
Jdforrester-WMF claimed this task.
Jdforrester-WMF removed a project: Patch-For-Review.

Change 439793 merged by jenkins-bot:
[mediawiki/core@master] Drop the LanguageGetSpecialPageAliases and LanguageGetMagic hooks

https://gerrit.wikimedia.org/r/439793