Page MenuHomePhabricator

Unable to access SWAP notebooks using LDAP
Closed, ResolvedPublic

Description

I'm trying to access SWAP via these instructions.

When I try to use my LDAP credentials to log into the Jupyter Hub, I get an "Invalid username and password" error.

I've confirmed that the same credentials still allow me to log in to wikitech.wikimedia.org successfully.

I've confirmed that I'm a member of the researchers access group.

I've also confirmed that I can tunnel in to bast1002 directly just fine.

Here's my SSH config:

Host bast1002.wikimedia.org
        ProxyCommand none
        ControlMaster auto

Host *.wikimedia.org *.wmnet !gerrit.wikimedia.org !git-ssh.wikimedia.org
        User jmorgan
        ProxyCommand ssh -a -W %h:%p bast1002.wikimedia.org
        IdentitiesOnly yes
        IdentityFile ~/.ssh/id_rsa

However, when I try the tunnel listed on SWAP#Access,

ssh -N notebook1003.eqiad.wmnet -L 8000:127.0.0.1:8000

...at first everything seems to work. Then I try...

http://localhost:8000/

...in a browser (Firefox 61, Mac), and I see a login page. Attempting to log in with LDAP credentials yields the invalid username or password error.

What am I missing? Any help appreciated!

  • If this isn't the right place for this question--please direct me to the right place :)
  • if you need more information to address my issue, lmk and I'll provide it as quickly as possible

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 16 2018, 11:15 PM
Capt_Swing updated the task description. (Show Details)Jul 16 2018, 11:19 PM
RobH added a subscriber: RobH.
This comment was removed by RobH.
Restricted Application added a project: Operations. · View Herald TranscriptJul 17 2018, 9:21 PM

Thanks @RobH. I added the wrong project by mistake.

RobH added a comment.Jul 17 2018, 9:40 PM

I thought it was perhaps access request, but then saw its likely and ldap fix and you had it right. I started to look into fixing it for you.

Since you are staff, there is no reason I cannot toss you into the wmf ldap group, which is now done. This should fix things for you.

RobH closed this task as Resolved.Jul 17 2018, 9:40 PM
RobH claimed this task.

(If it isn't fixed, reopen this task!)

RobH removed RobH as the assignee of this task.Jul 17 2018, 9:40 PM

Yep, that worked. Thank you, @RobH !