Page MenuHomePhabricator

[BlueSpiceSaferEdit] extension.json does not pass validation
Closed, ResolvedPublic

Description

There was 1 failure:

1) ExtensionJsonValidationTest::testPassesValidation with data set #0 ('/home/jenkins/workspace/mwext...n.json')
Failed asserting that '/home/jenkins/workspace/mwext-testextension-hhvm-composer-jessie-non-voting/src/extensions/BlueSpiceSaferEdit/extension.json did not pass validation.
[AutoloadNamespaces] The property BlueSpice\SaferEdit\\Tests is not defined and the definition does not allow additional properties
' matches expected false.

/home/jenkins/workspace/mwext-testextension-hhvm-composer-jessie-non-voting/src/tests/phpunit/structure/ExtensionJsonValidationTest.php:66
/home/jenkins/workspace/mwext-testextension-hhvm-composer-jessie-non-voting/src/maintenance/doMaintenance.php:94

Caused by 1ca1078ccba5f69dc1bc3e2c9bdb72f80e114d6d

Details

Related Gerrit Patches:
mediawiki/extensions/BlueSpiceSaferEdit : masterRemove unexisting BlueSpice\\SaferEdit\\Tests
mediawiki/extensions/BlueSpiceSaferEdit : masterFix AutoloadNamespaces having too many backslashes

Event Timeline

hashar triaged this task as Normal priority.Jul 17 2018, 8:16 AM
hashar created this task.
hashar updated the task description. (Show Details)

Change 446246 had a related patch set uploaded (by Hashar; owner: Hashar):
[mediawiki/extensions/BlueSpiceSaferEdit@master] Fix AutoloadNamespaces having too many backslashes

https://gerrit.wikimedia.org/r/446246

Change 446246 merged by jenkins-bot:
[mediawiki/extensions/BlueSpiceSaferEdit@master] Fix AutoloadNamespaces having too many backslashes

https://gerrit.wikimedia.org/r/446246

Change 446252 had a related patch set uploaded (by Hashar; owner: Hashar):
[mediawiki/extensions/BlueSpiceSaferEdit@master] Remove unexisting BlueSpice\\SaferEdit\\Tests

https://gerrit.wikimedia.org/r/446252

Change 446252 merged by jenkins-bot:
[mediawiki/extensions/BlueSpiceSaferEdit@master] Remove unexisting BlueSpice\\SaferEdit\\Tests

https://gerrit.wikimedia.org/r/446252

hashar closed this task as Resolved.Jul 17 2018, 10:30 AM
hashar claimed this task.