Enabling moved paragraphs everywhere and for mobile diffs
Closed, ResolvedPublic2 Story Points

Description

Enable moved paragraphs everywhere including Japanese, Chinese and Thai languages and on mobile by making the detection available with the corresponding ini setting.

  • prepare the config patch to enable it on Japanese, Chinese and Thai and mobile
  • coordinate with comm
  • book a SWAT window
  • accompany SWAT deploy

Tests for Japanese, Chinese and Thai language looked fine, see T197664 . Also the styles for mobile inline changes are deployed and ready.

This should happen on the 23rd of August.

WMDE-Fisch set the point value for this task to 2.
WMDE-Fisch moved this task from Sprint Backlog to Doing on the WMDE-QWERTY-Sprint-2018-08-14 board.
WMDE-Fisch renamed this task from Enabling moved paragraphs for mobile diffs to Enabling moved paragraphs everywhere and for mobile diffs.Aug 20 2018, 1:29 PM
WMDE-Fisch updated the task description. (Show Details)

Change 454019 had a related patch set uploaded (by WMDE-Fisch; owner: WMDE-Fisch):
[operations/mediawiki-config@master] Enable moved paragrah detection everywhere

https://gerrit.wikimedia.org/r/454019

Change 454026 had a related patch set uploaded (by WMDE-Fisch; owner: WMDE-Fisch):
[operations/mediawiki-config@master] Enable moved paragrah detection everywhere

https://gerrit.wikimedia.org/r/454026

WMDE-Fisch updated the task description. (Show Details)Aug 20 2018, 2:29 PM
WMDE-Fisch moved this task from Doing to Review on the WMDE-QWERTY-Sprint-2018-08-14 board.

@Addshore When this is enabled and works you would see moved paragraphes in the inline diff on production e.g.:

https://de.m.wikipedia.org/wiki/Spezial:Mobiler_Unterschied/169304779...169305386

should look like

https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:MobileDiff/377595

Change 454026 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable moved paragrah detection everywhere

https://gerrit.wikimedia.org/r/454026

Mentioned in SAL (#wikimedia-operations) [2018-08-23T11:18:53Z] <addshore@deploy1001> Synchronized wmf-config/CommonSettings.php: T199800 [[gerrit:454026|Enable moved paragrah detection everywhere]] (duration: 00m 55s)

Change 454019 merged by jenkins-bot:
[operations/mediawiki-config@master] Cleanup wikdiff2 mobile moved paragraph config

https://gerrit.wikimedia.org/r/454019

I confirmed this is live now. However, not all old diffs will immediately change. (I'm not even sure this would be a good idea because of the load spike it would create.)

This diff still looks old (red and green instead of orange) and will continue to do so for a maximum of 7 days (or less): https://de.m.wikipedia.org/wiki/Spezial:Mobiler_Unterschied/169304779...169305386

I copied the same edit to a sandbox page to confirm the config change really is in effect: https://de.m.wikipedia.org/wiki/Spezial:Mobiler_Unterschied/180261381

Mentioned in SAL (#wikimedia-operations) [2018-08-23T11:50:22Z] <addshore@deploy1001> Synchronized wmf-config: T199800 [[gerrit:Cleanup wikdiff2 mobile moved paragraph config]] (duration: 00m 55s)

This has been deployed and is enabled in all Wikis. Please note that wikitext diffs are cached for up to 7 days. Therefore it might take a few days until old diffs get regenerated.

thiemowmde triaged this task as Normal priority.Aug 23 2018, 3:26 PM
thiemowmde removed a project: Patch-For-Review.
thiemowmde moved this task from Review to Done on the WMDE-QWERTY-Sprint-2018-08-14 board.
thiemowmde closed this task as Resolved.