Page MenuHomePhabricator

using the importDump.php script is adding imported> to the username field for revision
Closed, DeclinedPublic

Description

Hi, since upgrading to mediawiki 1.31 we are noticing that the imported> prefix is being added to the username fields (ui)

I am using mediawiki 1.31 and php 7.2

Event Timeline

Paladox created this task.Jul 21 2018, 8:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 21 2018, 8:00 PM
Reedy renamed this task from using the importDump.php script is adding import> to the username field for revision to using the importDump.php script is adding imported> to the username field for revision.Jul 21 2018, 10:12 PM
Reedy updated the task description. (Show Details)
Reedy added a comment.EditedJul 21 2018, 10:19 PM

Possibly related to https://gerrit.wikimedia.org/r/#/c/mediawiki/core/+/386625/ ? And it might actually be a feature, not a bug

TTO added subscribers: Anomie, TTO.Jul 21 2018, 10:42 PM

Yep, this is correct behaviour. The idea is that when importing from another wiki, the usernames do not relate to users on your wiki, so they are distinguished with this prefix.

Is this causing problems for you (i.e. are you importing from your wiki to itself, or something)?

We are importing from a import a user gave us to import. Just found that import> prefix to be weird.

TTO closed this task as Declined.Jul 22 2018, 1:44 AM

OK. This behaviour is by design, so I'm going to close this task.

Note that if you're using importDump.php to import the pages, you are supposed to be able to change the user prefix that gets used (this is currently broken though, see T200138).