Page MenuHomePhabricator

Does not work for change a log type drop down when the log type specified by URL / argument @ 1.32.0-wmf.13 (360f7b5)
Closed, ResolvedPublic

Description

Event Timeline

Rxy created this task.Jul 21 2018, 8:37 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 21 2018, 8:37 PM

Confirmed. Regression. This is separate from
T199856, which is also a regression from the SpecialLog refactor from this week.

Krinkle triaged this task as High priority.Jul 21 2018, 8:50 PM

This should be fixed by just replacing like

$htmlForm = new HTMLForm( $formDescriptor, $this->getContext() );

to

$context = new DerivativeContext( $this->getContext() );
$context->setTitle( $this->getPageTitle() ); // Remove subpage
$htmlForm = new HTMLForm( $formDescriptor, $context );

in mediawiki/core/includes/logging/LogEventsList.php

DerivativeContext is important for form submission to override the title.

Getting Fatal Error undefined method LogEventsList::getPageTitle() because getPageTitle() is part of SpecialPage class.

Change 447359 had a related patch set uploaded (by Prtksxna; owner: Prtksxna):
[mediawiki/core@master] LogEventsList: Use DerivativeContext

https://gerrit.wikimedia.org/r/447359

Getting Fatal Error undefined method LogEventsList::getPageTitle() because getPageTitle() is part of SpecialPage class.

Yep, LogEventsList gets this using SpecialPage::getTitleFor( 'Log' ) - https://github.com/wikimedia/mediawiki/blob/master/includes/logging/LogEventsList.php#L113

zeljkofilipin raised the priority of this task from High to Unbreak Now!.Jul 23 2018, 3:24 PM
zeljkofilipin added a subscriber: zeljkofilipin.

Changing priority to UBN since it's blocking the train.

Friendly reminder: the train is blocked because of this task. (It's not the only blocker at the time I write this.) Any updates?

Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptJul 23 2018, 3:24 PM

Someone needs to merge the https://gerrit.wikimedia.org/r/447359. Everything is ready.

Thanks for the patch @Jayprakash12345, I just +2'd it.

I will not be around to SWAT it this time, so someone else will have to do it.

Change 447359 merged by jenkins-bot:
[mediawiki/core@master] LogEventsList: Use DerivativeContext

https://gerrit.wikimedia.org/r/447359

Change 447466 had a related patch set uploaded (by Greg Grossmeier; owner: Prtksxna):
[mediawiki/core@wmf/1.32.0-wmf.13] LogEventsList: Use DerivativeContext

https://gerrit.wikimedia.org/r/447466

greg added a subscriber: greg.Jul 23 2018, 4:39 PM

Change 447466 had a related patch set uploaded (by Greg Grossmeier; owner: Prtksxna):
[mediawiki/core@wmf/1.32.0-wmf.13] LogEventsList: Use DerivativeContext
https://gerrit.wikimedia.org/r/447466

Clarifying question: is this backport sufficient?

Yes, that fixes the issue.

Prtksxna closed this task as Resolved.Jul 24 2018, 1:41 AM
Prtksxna assigned this task to Jayprakash12345.
Restricted Application added a project: User-Jayprakash12345. · View Herald TranscriptJul 24 2018, 1:41 AM

Change 447466 abandoned by Zfilipin:
LogEventsList: Use DerivativeContext

Reason:
No wikis at .13 any more

https://gerrit.wikimedia.org/r/447466