Page MenuHomePhabricator

L10n-bot keeps deleting apihelp message from qqq.json
Closed, ResolvedPublic

Description

We recently added an api param 'variant' for the donate action in the DonationInterface extension.
Following the usual convention, we added the string 'apihelp-donate-param-variant' to en.json and qqq.json: https://gerrit.wikimedia.org/r/445451

In i18n-bot's next update, it removed the qqq.json message while adding translations for some other messages: https://gerrit.wikimedia.org/r/445682

I un-did the qqq.json damage: https://gerrit.wikimedia.org/r/445726
but i18n-bot removed the message again the next day (without doing anything else): https://gerrit.wikimedia.org/r/445811

Again reverted: https://gerrit.wikimedia.org/r/446046
And again i18n-bot removed the message: https://gerrit.wikimedia.org/r/446137

Reverted by @Raymond: https://gerrit.wikimedia.org/r/446183
And damaged again by i18n-bot: https://gerrit.wikimedia.org/r/446419

Reverted by me: https://gerrit.wikimedia.org/r/446475
And again damaged: https://gerrit.wikimedia.org/r/446657

This is getting really tiresome! Every time the message is deleted, all our tests fail on the next patch.

Event Timeline

Ejegg created this task.Jul 23 2018, 4:02 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 23 2018, 4:02 PM

Thanks @Ejegg for creating this task.

@Nikerabbit: For the record: Last week I have deleted the DonationInterface repo on translatewiki.net ( /resources/projects/mediawiki-extensions/DonationInterface) to let it clone again with the next sync to exclude a broken repo as error cause. Sadly this did not help :-(

I have no idea why this happens again and again.

I will give it a last try this night. If the message is deleted from qqq.json again I will revert it immediately and disable the extension until we have found the cause of it,

Change 447551 had a related patch set uploaded (by Raimond Spekking; owner: Raimond Spekking):
[translatewiki@master] [Donation Interface - Gateway Common] Disabled for now per T200212

https://gerrit.wikimedia.org/r/447551

Change 447551 merged by Raimond Spekking:
[translatewiki@master] [Donation Interface - Gateway Common] Disabled for now per T200212

https://gerrit.wikimedia.org/r/447551

I can check next week when I'm back.

Change 450979 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/Translate@master] ExternalMessageSourceStateComparator: Fix a regression of not always processing the source language

https://gerrit.wikimedia.org/r/450979

Nikerabbit moved this task from Backlog to In Review on the Language-2018-July-September board.

Took a bit longer due to various other things. Proposed patch already cherry-picked to translatewiki.net and confirmed working.

Petar.petkovic triaged this task as High priority.Aug 7 2018, 2:36 PM

Change 450979 merged by jenkins-bot:
[mediawiki/extensions/Translate@master] Fix a regression of not syncing the source language

https://gerrit.wikimedia.org/r/450979

Petar.petkovic moved this task from In Review to QA on the Language-2018-July-September board.
Petar.petkovic removed a subscriber: gerritbot.
Ejegg added a comment.Aug 8 2018, 1:30 PM

Thanks, @Nikerabbit ! It's great to see new translations coming in for DonationInterface again.

Nikerabbit closed this task as Resolved.Aug 15 2018, 3:23 PM
Nikerabbit renamed this task from i18n-bot keeps deleting apihelp message from qqq.json to L10n-bot keeps deleting apihelp message from qqq.json.Aug 28 2018, 7:06 AM