Page MenuHomePhabricator

CX2: Section alignment still sluggish and breakable
Closed, ResolvedPublic

Description

Section alignment is still sluggish when you add lots of sections to the translation in quick succession.

It breaks from time to time and inserting new section usually fixes everything, but sometimes there aren't any sections to add. This is completely translated page, loaded from in-progress:


This is just one example. Using the tool lately to test the patches revealed lots of broken alignments.

Event Timeline

santhosh updated the task description. (Show Details)Aug 8 2018, 10:55 AM

Example from description seems fixed, but again, that is just one example. Alignment still breaks often

While translating en:Hyphen-minusWhen draft is loaded (en:Arable_land)
Restricted Application changed the subtype of this task from "Deadline" to "Task". · View Herald TranscriptAug 24 2018, 8:38 AM

Example from description seems fixed, but again, that is just one example. Alignment still breaks often

Have we identified which are the causes for these missalignments, or identifying them is part of the work to be done in the ticket?

Example from description seems fixed, but again, that is just one example. Alignment still breaks often

Have we identified which are the causes for these missalignments, or identifying them is part of the work to be done in the ticket?

Investigation about the causes is part of the work needed to be done.

Change 458354 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] Section alignment: Do a quick test to determine the need of alignment

https://gerrit.wikimedia.org/r/458354

santhosh claimed this task.Sep 6 2018, 7:56 AM

Change 460206 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] For the restored section, give matching id with source section

https://gerrit.wikimedia.org/r/460206

Change 460206 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] For the restored section, give matching id with source section

https://gerrit.wikimedia.org/r/460206

Change 458354 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Section alignment: Do a quick test to determine the alignment need

https://gerrit.wikimedia.org/r/458354

Change 461355 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] Alignment: Use minHeight to enforce height instead of height

https://gerrit.wikimedia.org/r/461355

There is still one unmerged patch linked to this ticket - 461355.
It's currently marked as WIP and @Nikerabbit moved this ticket to QA, so I guess previous work and patches which are already merged are meant to be verified.

Etonkovidova closed this task as Resolved.EditedOct 26 2018, 11:29 PM

Checked all examples mentioned in the ticket (including en:Uma Thurman mentioned in unmrged patch https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/ContentTranslation/+/461355/) in production (wmf.1) and cx2

  • Uma Thurman (en->es, ca)
  • -an (en_>es)
  • Hyphen-minus
  • Arable land

The screenshots illustrate that there are no problems with alignment:

Uma Turman article - the translated infobox occupies much more of a vertical space than the original one, but all paragraphs get accommodated correctly in terms of a space:

During testing (on many different articles' layouts), I haven't found yet any cases of misalgnment, so I mark this ticket as Resolved.

Note: There was a recent report - https://www.mediawiki.org/wiki/Topic:Unbemf1hiccy8u8s - that some article (Education in China) was misaligned. However, no details were given - cx version, from which language to which lang etc

Change 461355 abandoned by Santhosh:
Alignment: Use minHeight to enforce height instead of height

https://gerrit.wikimedia.org/r/461355