Page MenuHomePhabricator

CX2: Uncaught ReferenceError: specialPageWhitelist is not defined
Closed, InvalidPublic

Description

  • Article: en:Mumbai -> hi
  • Environment: Production (wmf.13)
Uncaught ReferenceError: specialPageWhitelist is not defined
    at HTMLDocument.Twinkle.load (load.php?debug=true&lang=hi&modules=ext.gadget.Twinkle&only=scripts&skin=vector&version=0s1lcys:6425)
    at mightThrow (load.php?debug=true&lang=hi&modules=jquery|mediawiki.base|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=19lyfvl:3583)
    at process (load.php?debug=true&lang=hi&modules=jquery|mediawiki.base|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=19lyfvl:3651)

It mostly coming from broken gadget on hiwiki, so need to fix there?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 25 2018, 12:43 PM

Yep, ext.gadget.Twinkle. How does this impact CX, or is this just relatively harmless error in the console?

Harmless errors so far.

Arrbee moved this task from Needs Triage to CX2 on the ContentTranslation board.Aug 6 2018, 10:14 AM
Arrbee moved this task from CX2 to Check & Move on the ContentTranslation board.Jul 8 2019, 1:38 PM
Arrbee triaged this task as Low priority.Jul 8 2019, 2:22 PM
Jpita added a subscriber: Jpita.EditedJul 18 2019, 10:21 PM

@KartikMistry can u tell me how to replicate this error?
Also, I see no code here, was there no change?

Arrbee moved this task from Check & Move to Bugs on the ContentTranslation board.Jul 22 2019, 1:13 PM

@KartikMistry can u tell me how to replicate this error?
Also, I see no code here, was there no change?

Try example given. It is due to gadget in hiwiki. Let me know if you're able to reproduce.

Jpita added a comment.Jul 25 2019, 9:10 AM

I get two errors when loading the translation, are these related?

I get two errors when loading the translation, are these related?

Seems unrelated. Need to investigate separately.

Jpita added a comment.Aug 29 2019, 4:16 PM

@KartikMistry any update on this?

KartikMistry closed this task as Invalid.Sep 26 2019, 7:51 AM

@KartikMistry any update on this?

I'm no longer able to reproduce this. Closing.