Page MenuHomePhabricator

DPLForum: Double-encoded link text on the generated list (at least for double quotes)
Closed, ResolvedPublic

Description

Extension:DPLforum

I created a forum page with double quotes in the name. The <forum> tag lists the page displaying "&quot;" instead of double quotes. The link target however works correctly. Looks like it's double-encoding the link text.

The example can be seen here: https://www.wikidex.net/wiki/Foro:Index

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 29 2018, 8:24 PM
Ciencia_Al_Poder added a subscriber: ashley.

Adding ashley as cc since he's the only de-facto maintainer (at least in the previous 2-3 years). I can probably come up with a patch if nobody does that before. Tagging as easy because it looks easy to reproduce and fix.

Change 449110 had a related patch set uploaded (by Jack Phoenix; owner: Jack Phoenix):
[mediawiki/extensions/DPLforum@master] Don't double-escape the displayed link title

https://gerrit.wikimedia.org/r/449110

Change 449110 merged by jenkins-bot:
[mediawiki/extensions/DPLforum@master] Don't double-escape the displayed link title

https://gerrit.wikimedia.org/r/449110

Ciencia_Al_Poder closed this task as Resolved.Jul 31 2018, 9:12 AM
Ciencia_Al_Poder assigned this task to ashley.