Page MenuHomePhabricator

PHP Notice: Undefined index from extensions/FileImporter/src/Services/WikiTextContentCleaner.php:83
Closed, ResolvedPublic

Description

Seen in Logstash since 1.32.0.wmf.13, does not appear to be present in wmf.12 and earlier so likely a recent regression.

[{exception_id}] {exception_url} ErrorException from line 83 of /srv/mediawiki/php-1.32.0-wmf.14/extensions/FileImporter/src/Services/WikiTextContentCleaner.php: PHP Notice: Undefined index: 3
[{exception_id}] {exception_url} ErrorException from line 81 of /srv/mediawiki/php-1.32.0-wmf.13/extensions/FileImporter/src/Services/WikiTextContentCleaner.php: PHP Notice: Undefined index: 2

  • /srv/mediawiki/php-1.32.0-wmf.14/extensions/FileImporter/src/Services/WikiTextContentCleaner.php:83
  • /srv/mediawiki/php-1.32.0-wmf.13/extensions/FileImporter/src/Services/WikiTextContentCleaner.php:81
Details
message:
PHP Notice: Undefined index: 3

exception_url:
/wiki/Special:ImportFile

http_method:
POST

server:
commons.wikimedia.org

exception.trace:

#0 /srv/mediawiki/php-1.32.0-wmf.14/extensions/FileImporter/src/Services/WikiTextContentCleaner.php(83): MWExceptionHandler::handleError(integer, string, string, integer, array, array)
#1 /srv/mediawiki/php-1.32.0-wmf.14/extensions/FileImporter/src/Services/WikiTextContentCleaner.php(41): FileImporter\Services\WikiTextContentCleaner->cleanTemplates(string)
#2 /srv/mediawiki/php-1.32.0-wmf.14/extensions/FileImporter/src/Remote/MediaWiki/ApiDetailRetriever.php(275): FileImporter\Services\WikiTextContentCleaner->cleanWikiText(string)
#3 /srv/mediawiki/php-1.32.0-wmf.14/extensions/FileImporter/src/Services/SourceSite.php(68): FileImporter\Remote\MediaWiki\ApiDetailRetriever->getImportDetails(FileImporter\Data\SourceUrl)
#4 /srv/mediawiki/php-1.32.0-wmf.14/extensions/FileImporter/src/SpecialImportFile.php(267): FileImporter\Services\SourceSite->retrieveImportDetails(FileImporter\Data\SourceUrl)
#5 /srv/mediawiki/php-1.32.0-wmf.14/extensions/FileImporter/src/SpecialImportFile.php(172): FileImporter\SpecialImportFile->getImportPlan()
#6 /srv/mediawiki/php-1.32.0-wmf.14/includes/specialpage/SpecialPage.php(566): FileImporter\SpecialImportFile->execute(NULL)
#7 /srv/mediawiki/php-1.32.0-wmf.14/includes/specialpage/SpecialPageFactory.php(569): SpecialPage->run(NULL)
#8 /srv/mediawiki/php-1.32.0-wmf.14/includes/MediaWiki.php(288): SpecialPageFactory::executePath(Title, RequestContext)
#9 /srv/mediawiki/php-1.32.0-wmf.14/includes/MediaWiki.php(867): MediaWiki->performRequest()
#10 /srv/mediawiki/php-1.32.0-wmf.14/includes/MediaWiki.php(524): MediaWiki->main()
#11 /srv/mediawiki/php-1.32.0-wmf.14/index.php(42): MediaWiki->run()
#12 /srv/mediawiki/w/index.php(3): include(string)
#13 {main}

Event Timeline

Krinkle created this task.Jul 31 2018, 7:01 PM
thiemowmde triaged this task as Normal priority.Aug 10 2018, 2:53 PM
thiemowmde moved this task from Incoming to Move files to Commons on the TCB-Team board.
thiemowmde added subscribers: Lea_WMDE, WMDE-Fisch.

As a user reported in T198711 the mistake in the code responsible for this error also created a user-facing issue. We already resolved this via https://gerrit.wikimedia.org/r/448565, and backported to the wmf/1.32.0-wmf.14 branch via https://gerrit.wikimedia.org/r/448801. We did not bothered backporting to the wmf.13 branch since Commons was on wmf.14 already at this point in time.

Would be lovely if someone could check if this error is still present in recent logs.

Krinkle closed this task as Resolved.Aug 11 2018, 12:37 AM
Krinkle assigned this task to thiemowmde.

Thanks. Logstash shows the last instance was on 2018-07-30 (wmf.14). No entries since then on wmf.15 and later.

mmodell changed the subtype of this task from "Task" to "Production Error".Aug 28 2019, 11:09 PM