Page MenuHomePhabricator

CX2: Alignment broken after adding a template
Closed, ResolvedPublic

Description

Although broken alignment is topic of T200323: CX2: Section alignment still sluggish and breakable, this ticket is describing more specific case. While testing T199308 with en:Uma_Thurman page, I have once again witnessed broken alignment, which remains broken until new paragraph is added.
Here are two screenshots showing how template overlaps two sections. Placeholders appear on top of template.


Event Timeline

santhosh updated the task description. (Show Details)Aug 8 2018, 10:03 AM
Restricted Application changed the subtype of this task from "Deadline" to "Task". · View Herald TranscriptSep 18 2018, 11:45 AM

Change 461115 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] Register TransclusionNode rerender as a section change

https://gerrit.wikimedia.org/r/461115

Change 461115 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Register TransclusionNode rerender as a section change

https://gerrit.wikimedia.org/r/461115

Etonkovidova closed this task as Resolved.Sep 22 2018, 12:56 AM
Etonkovidova added a subscriber: Etonkovidova.

The issue is not present anymore in cx2 - even when the translated template occupies more space then in the source article, the content will be shifted down accordingly, so no overlap would happen.

Petar.petkovic removed a subscriber: gerritbot.