Page MenuHomePhabricator

Change group rights in Russian Wikinews (move, rollback)
Closed, ResolvedPublic

Description

According with consensus: https://ru.wikinews.org/wiki/Викиновости:Форум/Общий#Изменение_в_групповых_правах_по_переименованиям

Please change the following group rights in Russian Wikinews (https://ru.wikinews.org/; Special:ListGroupRights: https://ru.wikinews.org/wiki/Служебная:Права_групп_участников).

  • move-categorypages
    • Remove from group "Участники" (Users).
    • Add to group "Автодосматривающие" (Autoreview).
  • movestable
    • Remove from group "Автоподтверждённые участники" (Autoconfirmed users).
    • Add to group "Автодосматривающие" (Autoreview).
  • Create the group "Откатывающие" (Rollbackers) with "rollback" right. Add to administrators the ability to add/remove users to/from this group.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 5 2018, 2:36 PM
Base added a subscriber: Base.Aug 5 2018, 2:49 PM
Arbnos added a subscriber: Arbnos.Aug 5 2018, 3:19 PM
Base added a comment.Aug 5 2018, 3:20 PM

What you probably mean is for autoreview AND editor to now have the rights. Could you confirm?

Krassotkin updated the task description. (Show Details)Aug 5 2018, 3:33 PM

What you probably mean is for autoreview AND editor to now have the rights. Could you confirm?

Do you mean to add these rights (move-categorypages, movestable) to the group of editors too?

Base added a comment.Aug 5 2018, 4:36 PM

Well, by what you have requested only admins (администраторы) and autoreviewers (автодосматривающие) will have the rights but not editors (патрулирующие). This makes rather little sense.

For example I would be able to use those tools (I am an autoreviewer) but Dmitry Rozhkov who is an editor but not autoreviewer would be not.

Thus yes, I suggest to add the rights to the group of editors too.

@Base: Thank you, then I correctly understood your question.

I consciously do it because I'm a supporter of the separation of constituent of group rights (like rollbacker in this request). Therefore, usually I don't remove editors from the autoreviewers group. After changing the group rights, I will do the necessary changes to the rights of the users.

In this particular case, it is necessary to do as the community has decided and as written in the request.

If you have any suggestions, they can be discussed before on the project pages with our community.

Base added a comment.Aug 5 2018, 6:19 PM

Okay, if it is a conscious decision rather than an overlook it is fine.

Urbanecm claimed this task.Aug 24 2018, 8:42 PM
Urbanecm triaged this task as Normal priority.
Urbanecm added a subscriber: Urbanecm.

Rewriting the request in English:

  • Removing move-categorypages from users and adding to autoreviewers
  • Removing movestable from autoconfirmed and adding to autoreview
  • Creating rollbackers, grantable by sysops
Restricted Application added a project: User-Urbanecm. · View Herald TranscriptAug 24 2018, 8:42 PM

Change 455232 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Permissions changes in ruwikinews

https://gerrit.wikimedia.org/r/455232

I've scheduled this to be deployed tomorrow, between 11:00 and 12:00 UTC.

Change 455232 merged by jenkins-bot:
[operations/mediawiki-config@master] Permissions changes in ruwikinews

https://gerrit.wikimedia.org/r/455232

Mentioned in SAL (#wikimedia-operations) [2018-08-28T11:34:37Z] <zfilipin@deploy1001> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:455232|Permissions changes in ruwikinews (T201265)]] (duration: 00m 48s)

Urbanecm closed this task as Resolved.Aug 28 2018, 11:58 AM

Deployed. Should you notice any problems, please reopen and comment.