Page MenuHomePhabricator

Add block-options to Special:CentralAuth
Closed, ResolvedPublic

Description

Hi! Could you please add the user's block options to section "Blocked status"? It would be very useful to see if an insulting user name is yet locally hidden (via global permission "hideuser") or still needs hiding (at least until global hidings will trigger local ones).

Kind regards
DerHexer


Version: unspecified
Severity: normal
URL: http://meta.wikimedia.org/wiki/Special:CentralAuth

Event Timeline

bzimport raised the priority of this task from to Low.Nov 21 2014, 10:32 PM
bzimport set Reference to bz18182.
bzimport added a subscriber: Unknown Object (MLST).
DerHexer created this task.Mar 26 2009, 8:46 PM

mike.lifeguard+bugs wrote:

*** This bug has been marked as a duplicate of bug 14476 ***

mike.lifeguard+bugs wrote:

Bah, not a dupe at all. I think I meant to dupe something else to bug 14476...

mhchen wrote:

Hi, I'd like to work on this bug, but this is my first experience with FOSS. Could somebody please help guide me in the right direction?

(In reply to comment #3)

Hi, I'd like to work on this bug, but this is my first experience with FOSS.
Could somebody please help guide me in the right direction?

These links might be useful:
https://www.mediawiki.org/wiki/How_to_become_a_MediaWiki_hacker
https://gerrit.wikimedia.org/r/gitweb?p=mediawiki/extensions/CentralAuth.git;a=tree

Hello Michael,
Thanks for your offer to contribute.
You will need to download latest MediaWiki and CentralAuth versions. Setting up a SUL test system may be a bit tricky.

Then you should dig into the MediaWiki code on how to do that. Are you familiar with php? We have some specific to do things (in this case you should look at the blocks system).

The mentioned https://www.mediawiki.org/wiki/How_to_become_a_MediaWiki_hacker is a good starting point.
Don't be afraid on using the options listed at Discuss for getting support with this.

sumanah wrote:

It looks like Michael's no longer working on this. Sucheta, you want to give it a try?

sucheta.ghoshal wrote:

(In reply to comment #6)

It looks like Michael's no longer working on this. Sucheta, you want to give
it
a try?

Sure! :)
Would love to work on this. Thanks! :)

cro0016 wrote:

Hi there. Taking a look at CentralAuth, I can't see Blocked status as an option or field anymore. Could you point out where you see it (As this bug was initially filed 4 years ago)

eg on https://meta.wikimedia.org/wiki/special:centralauth/google9999 you can see where that user is blocked in the 4th column. It gives the block length and reason atm.

Can somebody please give some more info on how to add the user block options and what should be they?

Block options are the stuff which is shown in brackets on Special:Log/block:

https://meta.wikimedia.org/w/index.php?title=Special%3ALog&type=block&user=&page=User%3ALeeny5432 - here: "(account creation disabled, cannot edit own talk page)".

(In reply to comment #11)

Can somebody please give some more info on how to add the user block options
and what should be they?

So in the ipblocks table, we store information like "block anonymous users only", "enable autoblock", "don't allow editing talk page" ([[mw:Manual:ipblocks table]]).

In CentralAuthUser::localUserData, we're currently only loading the expiry and reason. We would need to load the other information too, and in the Special:CentralAuth page, we would need to change the formatBlockStatus function to also handle options.

Is anyone working on this?

It's not assigned, no.

Change 127464 had a related patch set uploaded by Legoktm:
Show block options on Special:CentralAuth

https://gerrit.wikimedia.org/r/127464

Change 127464 had a related patch set uploaded (by Glaisher):
Show block options on Special:CentralAuth

https://gerrit.wikimedia.org/r/127464

Change 127464 merged by jenkins-bot:
Show block options on Special:CentralAuth

https://gerrit.wikimedia.org/r/127464

Krenair closed this task as Resolved.Apr 16 2015, 1:10 PM
Krenair assigned this task to Legoktm.
Meno25 removed a subscriber: Meno25.Nov 4 2016, 7:10 AM
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptNov 4 2016, 7:10 AM