Page MenuHomePhabricator

Test poolcounter support for ores in beta cluster
Closed, ResolvedPublic

Event Timeline

Ladsgroup triaged this task as High priority.Aug 13 2018, 12:05 PM
Ladsgroup created this task.

I tested it in labs setup and took me hours of wrestling until I realized "fab deploy*" doesn't update submodules in target nodes.......
Now it works, but it doesn't distribute locks and sends all to the first node. I double check why it's happening.

And nothing is wrong, is just pool counter is a lock manager and same key locks should go to one node and not several which is by design, the problem here begins when labs proxy turns all IPs to just one (not even two or three) meaning everything will indeed go to only one node...

And nothing is wrong, is just pool counter is a lock manager and same key locks should go to one node and not several which is by design, the problem here begins when labs proxy turns all IPs to just one (not even two or three) meaning everything will indeed go to only one node...

Hm, it probably makes sense to (aside from the IP which will vary per mediawiki machine quering the service internally) also look at X-Client-IP HTTP header and vary on it ?

We don't look at internal requests as all of them have the precache flag and we don't use lock manager for those.

Seems like this happened. Is it done?

Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptSep 19 2018, 8:37 PM
Ladsgroup moved this task from Incoming to Done on the User-Ladsgroup board.Oct 2 2018, 8:20 PM
Ladsgroup closed this task as Resolved.Nov 1 2018, 8:00 PM