Page MenuHomePhabricator

Add "pagequality" right to User rights when logged in via OAuth
Closed, ResolvedPublic

Description

I am using OAuth to login as Mpaa (via pywikibot) and I need to work with ProofreadPage extension.
ProofreadPage extension requires "pagequality" rights to allow cerrtain operations.

When I login with OAuth, such right is not granted.
How can it be added?

These are the rights that I see for Mpaa when logged in via OAuth (normally they are much more, including "pagequality"):

{"query":{"userinfo":{"id":257091,"name":"Mpaa","groups":["abusefilter","bureaucrat","sysop","*","user","autoconfirmed"],"rights":["noratelimit","suppressredirect","move","move-subpages","move-rootuserpages","move-categorypages","autopatrol","upload","reupload","reupload-shared","autoconfirmed","editsemiprotected","ipblock-exempt","markbotedits","apihighlimits","movefile","skipcaptcha","abusefilter-log-detail","massmessage","read","edit","createpage","createtalk","writeapi","abusefilter-view","abusefilter-log","reupload-own","minoredit","purge","applychangetags","changetags"]}}}

I am unsure where to address this ticket, I apologize if it is not routed correctly.
Thanks.

Details

Related Gerrit Patches:
mediawiki/extensions/ProofreadPage : masterextension.json: Add pagequality right to the editpage grant

Event Timeline

Mpaa created this task.Aug 14 2018, 9:48 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 14 2018, 9:48 AM
JJMC89 added a subscriber: JJMC89.Aug 14 2018, 2:07 PM

pagequality is not part of any of the grants. ProofreadPage should create a new grant or add it to an appropriate existing grant.

Mpaa added a subscriber: Tpt.Aug 14 2018, 5:18 PM

Thanks.
@Tpt, is this possible?
In my understanding missing "pagequality" rights with OAuth is the reason for T173385.

Mpaa added a comment.Oct 18 2018, 7:55 PM

@JJMC89. could you please elaborate about it? So I might try to look into it. Thanks

Change 468501 had a related patch set uploaded (by JJMC89; owner: JJMC89):
[mediawiki/extensions/ProofreadPage@master] extension.json: Add pagequality right to the basic grant

https://gerrit.wikimedia.org/r/468501

JJMC89 claimed this task.Oct 19 2018, 5:22 AM

@Mpaa Rights can be added to grants in extension.json. Doc: GrantPermissions

Change 468501 merged by jenkins-bot:
[mediawiki/extensions/ProofreadPage@master] extension.json: Add pagequality right to the editpage grant

https://gerrit.wikimedia.org/r/468501

JJMC89 closed this task as Resolved.Oct 19 2018, 6:14 PM
JJMC89 removed a project: Patch-For-Review.
Mpaa added a comment.Oct 19 2018, 8:31 PM

Thank you.