Page MenuHomePhabricator

Error in edit newsletter page: Call to a member function getPrefixedText() on null
Open, Needs TriagePublic

Description

After creating a newsletter, I go to edit page and get error:

[06455bd408a74e80a787a0c1] /index.php?title=Newsletter:%D0%9D%D0%BE%D0%B2%D1%8B%D0%B5_%D0%BF%D1%83%D0%B1%D0%BB%D0%B8%D0%BA%D0%B0%D1%86%D0%B8%D0%B8&action=edit Error from line 92 of /var/www/anthecologyorg/data/www/anthecology.org/extensions/Newsletter/includes/NewsletterEditPage.php: Call to a member function getPrefixedText() on null

Backtrace:

#0 /var/www/anthecologyorg/data/www/anthecology.org/extensions/Newsletter/includes/NewsletterEditPage.php(41): NewsletterEditPage->getManageForm()
#1 /var/www/anthecologyorg/data/www/anthecology.org/extensions/Newsletter/Newsletter.hooks.php(195): NewsletterEditPage->edit()
#2 /var/www/anthecologyorg/data/www/anthecology.org/includes/Hooks.php(195): NewsletterHooks::onCustomEditor(Article, User)
#3 /var/www/anthecologyorg/data/www/anthecology.org/includes/actions/EditAction.php(57): Hooks::run(string, array)
#4 /var/www/anthecologyorg/data/www/anthecology.org/includes/MediaWiki.php(495): EditAction->show()
#5 /var/www/anthecologyorg/data/www/anthecology.org/includes/MediaWiki.php(289): MediaWiki->performAction(Article, Title)
#6 /var/www/anthecologyorg/data/www/anthecology.org/includes/MediaWiki.php(851): MediaWiki->performRequest()
#7 /var/www/anthecologyorg/data/www/anthecology.org/includes/MediaWiki.php(512): MediaWiki->main()
#8 /var/www/anthecologyorg/data/www/anthecology.org/index.php(43): MediaWiki->run()
#9 {main}

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 15 2018, 11:25 AM
D3r1ck01 updated the task description. (Show Details)Aug 15 2018, 11:45 AM

Please provide MediaWiki version and extension version information.

MediaWiki 1.28.0
PHP 7.0.27-0+deb9u1 (apache2handler)
MariaDB 10.1.26-MariaDB-0+deb9u1
ICU 57.1
Newsletter 1.2.0 (83d6001)

Aklapper closed this task as Invalid.Aug 16 2018, 7:28 AM

MediaWiki 1.28.0 is too old and not supported anymore. Developers are no longer working on that version, so unfortunately there will not be any bug fixes by developers for the version that you use.
By upgrading to a newer version of MediaWiki you will receive bug fixes, security updates, and new functionality.

If the problem still occurs with a newer and supported version of MediaWiki, please set the status of this report back to "Open" via the Add Action...Change Status dropdown this report and provide exact version information. Thanks!

Antohabio reopened this task as Open.Sat, Feb 8, 9:33 PM

Current error on Mediawiki 1.33 too.

Aklapper renamed this task from Error in edit newsletter page to Error in edit newsletter page: Call to a member function getPrefixedText() on null.Sun, Feb 9, 5:10 AM

%D0%9D%D0%BE%D0%B2%D1%8B%D0%B5_%D0%BF%D1%83%D0%B1%D0%BB%D0%B8%D0%BA%D0%B0%D1%86%D0%B8%D0%B8

Personally to me, this URL sounds weird. Like, when you create a newsletter with the decoded Новые публикации, the newsletter is created at Newsletter:Newsletter:Новые_публикации. See screenshots:

Probably more information about what went into the input text on Special:RegisterNewsletter is worth looking at. If it looks like:

, then I cannot reproduce this URL you are looking at while editing.