Page MenuHomePhabricator

version 2.7.239-alpha-2018-08-20 crashes on android pie
Closed, ResolvedPublic1 Story PointsBUG REPORT

Description

Steps to reproduce

  1. Load page רשימת אתרי מורשת עולמית on he.wiki while using android pie (9)
  2. wait a second
  3. get a crash

Expected results

No crash

Actual results

crash

Stack trace

08-21 01:52:03.123  2339  2339 D org.wikipedia.page.PageFragmentLoadState: loadFromBackStack():171: Loaded page רשימת אתרי מורשת עולמית from backstack
08-21 01:52:03.124  1158  1212 I ActivityManager: Displayed org.wikipedia.alpha/org.wikipedia.page.PageActivity: +269ms
08-21 01:52:03.327  2339  2339 D org.wikipedia.page.PageFragmentLoadState: sendLeadSectionPayload():437: Sent message 'displayLeadSection' for page: רשימת אתרי מורשת עולמית
08-21 01:52:03.560  2339  2339 D WikipediaWeb: file:///android_asset/bundle.js:586 - TypeError: Cannot read property 'innerHTML' of null
08-21 01:52:03.587  2339  2339 D AndroidRuntime: Shutting down VM
08-21 01:52:03.588  2339  2339 E AndroidRuntime: FATAL EXCEPTION: main
08-21 01:52:03.588  2339  2339 E AndroidRuntime: Process: org.wikipedia.alpha, PID: 2339
08-21 01:52:03.588  2339  2339 E AndroidRuntime: java.lang.RuntimeException: org.json.JSONException: No value for disambiguations
08-21 01:52:03.588  2339  2339 E AndroidRuntime: 	at org.wikipedia.page.PageInfoUnmarshaller.unmarshal(PageInfoUnmarshaller.java:24)
08-21 01:52:03.588  2339  2339 E AndroidRuntime: 	at org.wikipedia.page.PageFragmentLoadState$2.onMessage(PageFragmentLoadState.java:299)
08-21 01:52:03.588  2339  2339 E AndroidRuntime: 	at org.wikipedia.page.PageFragmentLoadState$SynchronousBridgeListener.onMessage(PageFragmentLoadState.java:662)
08-21 01:52:03.588  2339  2339 E AndroidRuntime: 	at org.wikipedia.bridge.CommunicationBridge$1.handleMessage(CommunicationBridge.java:104)
08-21 01:52:03.588  2339  2339 E AndroidRuntime: 	at android.os.Handler.dispatchMessage(Handler.java:102)
08-21 01:52:03.588  2339  2339 E AndroidRuntime: 	at android.os.Looper.loop(Looper.java:193)
08-21 01:52:03.588  2339  2339 E AndroidRuntime: 	at android.app.ActivityThread.main(ActivityThread.java:6669)
08-21 01:52:03.588  2339  2339 E AndroidRuntime: 	at java.lang.reflect.Method.invoke(Native Method)
08-21 01:52:03.588  2339  2339 E AndroidRuntime: 	at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:493)
08-21 01:52:03.588  2339  2339 E AndroidRuntime: 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:858)
08-21 01:52:03.588  2339  2339 E AndroidRuntime: Caused by: org.json.JSONException: No value for disambiguations
08-21 01:52:03.588  2339  2339 E AndroidRuntime: 	at org.json.JSONObject.get(JSONObject.java:392)
08-21 01:52:03.588  2339  2339 E AndroidRuntime: 	at org.json.JSONObject.getJSONArray(JSONObject.java:587)
08-21 01:52:03.588  2339  2339 E AndroidRuntime: 	at org.wikipedia.page.PageInfoUnmarshaller.unmarshal(PageInfoUnmarshaller.java:21)
08-21 01:52:03.588  2339  2339 E AndroidRuntime: 	... 9 more
08-21 01:52:03.590  1158  4722 W ActivityManager:   Force finishing activity org.wikipedia.alpha/org.wikipedia.page.PageActivity
08-21 01:52:03.593  2339  2339 I Process : Sending signal. PID: 2339 SIG: 9

Environments observed

App version: 2.7.239-alpha-2018-08-20
Android OS versions: pie (9)
Device model: pixel 2
Device language:Hebrew

Event Timeline

Matanya created this task.Aug 20 2018, 10:58 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 20 2018, 10:58 PM
Dbrant added a subscriber: Dbrant.Aug 20 2018, 11:37 PM

I'm not sure this has anything to do with Android 9. The page causes the app to crash on other API versions, too.

Change 454181 had a related patch set uploaded (by Dbrant; owner: Dbrant):
[apps/android/wikipedia@master] Fix possible crash when collecting disambiguations in articles.

https://gerrit.wikimedia.org/r/454181

Change 454181 merged by jenkins-bot:
[apps/android/wikipedia@master] Fix possible crash when collecting disambiguations in articles.

https://gerrit.wikimedia.org/r/454181

Dbrant closed this task as Resolved.Aug 21 2018, 7:55 PM
Dbrant claimed this task.

Please reopen if still happening on latest alpha.

Fixed, thank you!