Page MenuHomePhabricator

Edit interface loaded with double toolbar on mobile web
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. On your mobile device, go to https://en.m.wikipedia.org/wiki/Claude_Debussy
  2. Open the visual editor

Expected:

  • The edit interface loads with only one toolbar

Actual:

  • Two identical toolbars are loaded, and remained throughout the edit session

Event Timeline

Deskana created this task.Aug 22 2018, 11:19 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 22 2018, 11:19 AM
Deskana triaged this task as Medium priority.Aug 22 2018, 11:20 AM
Deskana moved this task from To Triage to Up next on the VisualEditor board.

This seems to happen on any sufficiently large article, such as https://en.m.wikipedia.org/wiki/Stockport:

Deskana moved this task from Up next to Current work on the VisualEditor board.Aug 22 2018, 5:25 PM
Deskana edited projects, added VisualEditor (Current work); removed VisualEditor.
Esanders added a subscriber: Esanders.EditedAug 22 2018, 6:48 PM

@Deskana: I'm not seeing this on my Android device (even with 4x CPU throttling). I do see some toolbar weirdness though, as the stylesheets are loading:

I'll look into the toolbar issue shown above though - it looks like we're showing the editing surface too early on mobile.

Esanders moved this task from Incoming to In progress on the VisualEditor (Current work) board.

Change 454821 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Don't wait for surface to blur before hiding pageToolbar

https://gerrit.wikimedia.org/r/454821

I saw the bug described locally, so I'm confident the issue I saw above is a separate issue, so I'll separate the tasks.

When I inspected the DOM, it looked like the whole editor had be initialised twice, both the toolbar and the content area. I suspect this bug is coming from MobileFrontend (perhaps the way it uses historyState to navigate), so I'll look into preventing the editor from loading twice. I suspect this may be the same cause as T202517, as I've only seen both bugs at the same time.

Change 455826 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/MobileFrontend@master] Guard against VE overlay being shown twice

https://gerrit.wikimedia.org/r/455826

Change 455826 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Guard against VE overlay being shown twice

https://gerrit.wikimedia.org/r/455826

I was able to reproduce the original issue @Deskana reported, will check both these issues once the fix lands on production.

This is going to be moved to "Done" column, once it's verified on production next week.

Not seeing two toolbars anymore. Verified.

Deskana closed this task as Resolved.Sep 28 2018, 10:02 AM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptSep 28 2018, 10:02 AM