Page MenuHomePhabricator

"Leave site?" message erroneously shown after user has saved an edit and is back in read mode
Closed, ResolvedPublic

Description

User edits and after pushing [publish], gets a message "leave page? changes you made may not be saved"

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 22 2018, 10:06 PM
Deskana changed the task status from Open to Stalled.Aug 23 2018, 11:41 AM
Deskana added a subscriber: Deskana.

I can't reproduce this problem. Here's what I tried:

  1. Go to https://office.wikimedia.org/wiki/Leadership/Executive_Team_Weekly_Updates/2018_August_7 (which seems to be the exact page you were on)
  2. Click "Edit" to open the visual editor
  3. Make some changes
  4. Click "Publish"
  5. Navigate away from the page using a link on the page

All of these steps worked as expected, and no error message was shown to me. I also tried the same steps except I started out in the wikitext editor and then switched to the visual editor, and started out in the wikitext editor and switched to the visual editor, and couldn't reproduce the problem.

Can you please provide more specific steps to reproduce?

Deskana renamed this task from Chrome message to "Leave site?" message erroneously shown after user has saved an edit and is back in read mode.Aug 23 2018, 11:45 AM

In Chrome:

  1. go to https://office.wikimedia.org/w/index.php?title=Leadership/Executive_Team_Weekly_Updates/2018_August_21 and click Edit, it takes me to wikitext editor.
  2. Switch to visual editor
  3. make some changes
  4. click Publish
  5. Get chrome warning

I don't always get the warning. I tried editing the same page and trying steps 1-4 more than once to see if it only happens the first time I try to save, but it happened twice on the same page.

Deskana triaged this task as Normal priority.Aug 24 2018, 4:47 PM
Deskana moved this task from To Triage to Up next on the VisualEditor board.

I've managed to reproduce this now. I had to disable the 2017 wikitext editor, and also use single edit tab mode set to wikitext editing by default.

Deskana changed the task status from Stalled to Open.Aug 24 2018, 4:47 PM

Thanks, @Deskana ! Let me know if you need more specifics from me.

Esanders claimed this task.Sep 6 2018, 12:46 PM

Change 458501 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Release editWarning unload event when switching from old wikitext to VE

https://gerrit.wikimedia.org/r/458501

Change 458501 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Release editWarning unload event when switching from old wikitext to VE

https://gerrit.wikimedia.org/r/458501

Deskana closed this task as Resolved.Sep 28 2018, 10:09 AM