Page MenuHomePhabricator

Clarify/document whether mapframe thumbnails are meant to be interactive or static
Closed, ResolvedPublic

Description

On English Wikipedia, when viewing a page with a mapframe map, a static thumbnail is shown and the dynamic version of the map is only available after maximising the map. When previewing (from wikitext edit mode), a dynamic thumbnail map (which can be zoomed in and out, and re-positioned by dragging with the mouse) is shown instead.

On test2wiki, mapframe thumbnail maps are interactive when viewing the page without needing to maximise them (see e.g. https://test2.wikipedia.org/wiki/Map_internationalization_examples ). This behaviour aligns with the documentation on https://www.mediawiki.org/wiki/Help:Extension:Kartographer :

code will insert a simple interactive map ... with the ability to maximize it by either double-clicking the map or clicking the icon in the right corner

So:

  • Is the documentation outdated? Normally I would assume so, but isn't test2wiki meant to be a newer version of the software...?
  • Or is this a configuration setting? In which case can this be documented at Help:Extension:Kartographer , and can test2wiki be configured like the production wikis (to avoid further confusion)?
  • Or is something else going on? (In any case, can the documentation still be clarified)

(Related on-wiki discussions: https://www.mediawiki.org/wiki/Topic:Uif37uh7adke8ee7 and https://en.wikipedia.org/w/index.php?title=User_talk:Evad37&oldid=856315833#Mapframe_for_infoboxes)

Event Timeline

Evad37 created this task.Aug 25 2018, 3:25 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 25 2018, 3:25 AM
Rehman added a subscriber: Rehman.Aug 25 2018, 1:03 PM
Mholloway triaged this task as Low priority.Aug 28 2018, 3:27 PM
Mholloway edited projects, added Maps (Kartographer); removed Maps.
CKoerner_WMF added a subscriber: CKoerner_WMF.EditedAug 29 2018, 3:16 PM

Thanks for pointing this inconsistency out.

Wikivoyage has the embedded interactive maps. Double-clicking opens the full-screen map.

All other production wikis have the static maps. Single-clicking opens the full-screen map.

The discrepancy, if not obvious, is that a single-click on an interactive map is used to pan the map. Hence the need for another action to go full-screen.

My guess (and I hope others can perhaps shed some light) as to why test2 has the interactive behavior is that was where the configuration for that wiki was left when the software was in active development. Not intentional, and given that more Wikimedia wikis use static maps should probably be changed.

As for the preview when editing. Yeah, that's unexpected (to me). I'm going to say that if you're editing on a wiki with static maps you should have a static preview; interactive maps, interactive preview. The goal is consistency in what you preview when editing and what folks see when reading.

However I'm not a product manager so I don't know if this is an intended behavior or an accidental outcome. Many moons ago the thought was that interactive embeds could be available everywhere. However the extra strain on resources ruled that out. Hence why the smaller (comparatively) Wikivoyage has the feature (along with being more map-centric and having a history of interactive embedded maps) and the rest do not.

I'm going to ping a few folks off-phab to get more input before I suggesting updating the documentation. I don't want to make it worse if I have my understanding wrong here. :)

Evad37 added a comment.Sep 4 2018, 3:03 AM

@CKoerner_WMF Did you get any further information, or should we update the Help page per what you've written above?

I haven't gotten feedback yet. Let's go ahead an explain the current state as I've described as it's closer to reality than what the docs currently suggest. :)

MSantos added a subscriber: MSantos.Sep 7 2018, 4:23 PM

The origin of this behavior is T191585: Release mapframe to all NON-Flagged Revs wikipedia (and a few who do have Flagged Revs). which had a patch that enabled the StaticMapFrame configuration for wikipedia and disabled it for test2wiki.

As @CKoerner_WMF said, we had in mind to enable the interactive mapframe everywhere, see T138057: Epic: Enable <mapframe> on Wikipedia.

What I think that can be done is clarify on documentation that mapframe can have two behaviors above, static and interactive, and where to expect this behavior (maybe?), while the work with T138057 is still incomplete.

Evad37 added a comment.EditedSep 11 2018, 3:35 AM

Note that the help page has been updated (diff), but I'm leaving this open since the configuration setting should probably be mentioned somewhere in https://www.mediawiki.org/wiki/Extension:Kartographer

MSantos moved this task from Unsorted to General on the Maps (Kartographer) board.Sep 11 2018, 2:15 PM
MSantos closed this task as Resolved.Sep 18 2018, 8:45 PM
MSantos claimed this task.

Documentation updated with configuration settings.