Page MenuHomePhabricator

[BUG] Showing an error page when trying to edit a redirected page
Closed, ResolvedPublicBug

Description

The issue happens on zh redirected Wikipedia pages.

Steps to reproduce

  1. In en Wikipedia, search Taiwan
  2. Tap on Other languages and click on Traditional Chinese to see the zh version of the article.
  3. Click on the link "菲律賓群島" to go to the article

Demo: https://youtu.be/Nr1TcmyE5AA

Scenario A:

  • Tap on the first pencil icon and select Edit introduction

Scenario B:

  • Long press on the texts to see the tooltip, and tap on the Edit here; or, go to the next section and tap on the pencil icon.

Expected

Able to edit the selected section.

Actual

Scenario A:

  • Showing a #REDIRECT tag with the an article title, and the issue is similar to the ticket T201213

Scenario B:

  • Showing An error occurred page.

Event Timeline

cooltey created this task.Aug 27 2018, 8:03 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 27 2018, 8:03 PM

Change 472751 had a related patch set uploaded (by Cooltey; owner: Cooltey):
[apps/android/wikipedia@master] Fix: Chinese variants issues that title in the lists does not match the article itself

https://gerrit.wikimedia.org/r/472751

cooltey claimed this task.Apr 9 2019, 6:48 PM
cooltey updated the task description. (Show Details)
Charlotte triaged this task as Normal priority.Apr 18 2019, 11:44 AM
ABorbaWMF added a subscriber: ABorbaWMF.

Looks good to me on 2.7.279-alpha-2019-04-25

Dbrant closed this task as Resolved.Apr 29 2019, 6:54 PM
Shizhao moved this task from Backlog to Closed on the Chinese-Sites board.Apr 30 2019, 3:24 AM

Change 472751 abandoned by Dbrant:
Fix: Chinese variants issues that title in the lists does not match the article itself

Reason:
currently on github

https://gerrit.wikimedia.org/r/472751

Restricted Application changed the subtype of this task from "Task" to "Bug Report". · View Herald TranscriptMon, Aug 5, 8:08 PM