Page MenuHomePhabricator

[Bug] Page previews don't always appear when previous preview is quickly dismissed
Closed, DuplicatePublic

Description

Steps to Reproduce

  1. Visit a page on desktop https://en.wikipedia.org/wiki/Ouroboros#See_also.
  2. Hover over a link and show a preview.
  3. Move the cursor in and out between the two links such that preview for the last link appears the new link is entered.
  4. Stay hovered over the new link.

This is difficult to reproduce intentionally but it is quite a common occurrence when rabbitholing the wiki at length.

Expected Results

  • The new link preview is shown.

Actual Results

  • Nothing is shown. See "cyclic model" at the very end of this gif.

Environments Observed

Browser Version

  • Chromium v68.0.3440.106

OS Version

  • Ubuntu v18.04

Device Model

  • Desktop

Device Language

  • English

Event Timeline

Restricted Application changed the subtype of this task from "Deadline" to "Task". · View Herald TranscriptAug 27 2018, 8:16 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Jdlrobson raised the priority of this task from Normal to Needs Triage.EditedAug 27 2018, 11:55 PM
Jdlrobson added subscribers: ovasileva, Jdlrobson.

Will allow @ovasileva to set priority.
I'm unable to replicate this myself. A gif would help.

Move the cursor in and out between the two links such that preview for the last link appears the new link is entered.

I think this is badly worded, which might be why I'm struggling to replicate.

Update: I see there is a gif (https://drive.google.com/file/d/1fidRGrhkhV3xT0nfVAMqf4Mn7hAJ3Xig/view) just too big to embed in the task itself, but even with that gif I'm not really sure I understand this problem... o_O

ovasileva triaged this task as Normal priority.Aug 28 2018, 10:57 AM

I am able to replicate, although it takes some trying. Can't get a consistent pattern. Setting normal for now, but might bump down to low later