Page MenuHomePhabricator

Wishlist survey for CommTech
Closed, ResolvedPublic

Description

What is the problem?

The Community-Tech team needs CL help with facilitating the wishlist this year.

How can we help you?

This would include but isn't limited to:

  • Doing outreach before and during the survey
  • Helping setup the wishlist pages and making sure the translations are in
  • Responding to wishlist-related comments on proposals/survey talk pages and elsewhere
  • Being present during the Triage-a-thon for wishlist during 13-14-15 November (full day, PST)

What does success look like?

The wishlist survey concludes successfully with the result posted by beginning of December.

What is your deadline?

3rd December is the conclusion of the survey.

https://meta.wikimedia.org/wiki/2018_Community_Wishlist_Survey

Event Timeline

Niharika created this task.Aug 29 2018, 9:09 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 29 2018, 9:09 PM
Elitre added a subscriber: Elitre.Aug 30 2018, 7:45 AM

Thanks for filing this.

To clarify, we're waiting to learn more about work in the next quarter that we will need to do for Audiences, to figure out who among the Specialists can actually commit to this - although it's likely going to be a multiple people job, I think.

And I have just scheduled a meeting with @Niharika and Joe to make this progress :)

Elitre assigned this task to Johan.Sep 20 2018, 6:44 PM
Restricted Application added a project: User-Johan. · View Herald TranscriptSep 20 2018, 6:44 PM

Per our conversation - Johan, who has an extensive experience with this project already, will be the "lead", with @CKoerner_WMF to assist as needed, and @Aklapper who volunteered to also support in the final sprints (thank you so much!).
It is possible that others may join the effort exactly like it's happened in the past; in particular, we may try and involve more actively the groups we've worked with lately, tech ambassadors and tech translators, for a more efficient presence on the projects (in particular, smaller ones).
The current resource allocation may be subject to changes should Audiences communicate sudden urgency/needs elsewhere - however, we believe that this machine is well oiled and will do what we can to support the process to the best of our ability.

Johan moved this task from Backlog to Do soon on the User-Johan board.Sep 21 2018, 9:49 AM
Johan triaged this task as High priority.Sep 24 2018, 1:11 PM
Johan moved this task from Backlog to Oct-Dec-2018 on the CommRel-Specialists-Support board.
Elitre awarded a token.Oct 2 2018, 9:54 AM

I am also happy to announce that @Quiddity has also confirmed his availability to work on the Triage-a-thon phase of this project. @Niharika, I'll leave it to you to evaluate whether it may be helpful for the team to invite him to the office ;)

I am also happy to announce that @Quiddity has also confirmed his availability to work on the Triage-a-thon phase of this project. @Niharika, I'll leave it to you to evaluate whether it may be helpful for the team to invite him to the office ;)

❤️ I'm so happy to see this. This is the dream team! Thanks everyone for stepping forward to help with this.
I have a meeting setup with Johan and Chris for Friday the 12th. @Johan it would be great if you can add Nick and Andre to the meeting invite. I don't seem to have permissions.

I will start working on the wishlist main page next week and we can start doing outreach as soon as we feel ready. The survey begins October 29 so it's quite close. Since we are such a spread out team, I think async communications would work best. We can use this Phabricator ticket or etherpad/gdocs/email/ whatever other folks feel comfortable with to coordinate efforts. I'm super excited to have you all help out. It's going to be the best wishlist survey ever!

Johan added a comment.Oct 4 2018, 7:26 PM

Done. It's a bit late for @Aklapper but worst case he'll simply have to decline (or we could try to find a spot the week after).

Andre and I are both OoO next Friday, so the week after might be good.

Johan added a comment.EditedOct 4 2018, 8:24 PM

The only remotely potentially possible slot that week if all six of us are to be present would be Tuesday at 15:00 UTC, i.e. 8 AM Pacific Time, but only for 20 minutes.

Quiddity updated the task description. (Show Details)Oct 4 2018, 8:28 PM

@Elitre, as you know, we are a little concerned about this plan. To avoid misunderstandings, can you please quantify the number of hours that the respective CLs will be available, especially during the intensive period of the first three weeks of November? Thanks.

Johan added a comment.Oct 10 2018, 9:50 PM

@jmatazzoni Erica is unfortunately out of office for the time being. Let us talk about this when we meet on Friday.

Elitre added a comment.EditedOct 15 2018, 11:00 AM

@Elitre, as you know, we are a little concerned about this plan. To avoid misunderstandings, can you please quantify the number of hours that the respective CLs will be available, especially during the intensive period of the first three weeks of November? Thanks.

While I understand you'll meet soon with Johan, here's the current agreement per our previous conversation -
Johan and Chris to be both available now, while Andre should be available to reply to some comments once the various wishlist pages are set up and Nick will likely deal with the triage-a-thon phase.

How many hours do you think may be necessary, Joe? Do you already have a specific ask in this regard? Do you feel like any part of the work is currently stalled on us, perhaps?
The communications to the community part is mostly "automated". We've gone through that several times before, and we have a clear idea of what it entails, and it'd be totally doable even if we had just one person available right now.

I am confident things will look more rosy once the project is actually kickstarted. As we are committing to resource this project, we'll fix problems should they arise, no doubts around that. :)

The communications to the community part is mostly "automated". We've gone through that several times before, and we have a clear idea of what it entails, and it'd be totally doable even if we had just one person available right now.

It's automated only once we have the translations in. I'd appreciate it if someone can take up the task of writing up a message, getting it translated and posting it on village pumps across all projects.
We need to do the same for Central Notice banners.

Johan added a comment.Oct 15 2018, 8:54 PM

Of course. That's part of our support. What Erica meant was that we have a structure in place – we don't have to invent a communications strategy, just build on what we have done previous years. Anyway, we have scheduled a meeting on Wednesday, we should be able to iron this out then.

Johan moved this task from Do soon to Do now on the User-Johan board.Oct 25 2018, 8:20 PM
Johan closed this task as Resolved.Dec 1 2018, 7:56 PM

Our work here is done.

Johan moved this task from Do now to Archive on the User-Johan board.Jan 16 2019, 9:15 AM