Page MenuHomePhabricator

Wikistats: add functions you apply to dimensional data such as "accumulate"
Closed, ResolvedPublic3 Story Points

Description

Wikistats: add functions you apply to all data in UI such as "accumulate"

  • functions such us accumulate could be a "button" in the split that acts on data showing accumulation
  • state needs to be changed so it is accumulation aware
  • It interacts with time range component because time range needs to be changed to "all"

The total article metric becomes now the "accumulate" action in the UI for the new pages metric

Event Timeline

Nuria created this task.Aug 30 2018, 4:32 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 30 2018, 4:32 PM
Nuria renamed this task from Wikistats: add functions you apply to all data in UI such as "accumulate" to Wikistats: add functions you apply to dimensional data such as "accumulate".Aug 30 2018, 4:38 PM

Quick note on that idea: As per the discussion with @fdans and @Nuria yestderday, it would be great to implement the notion of function to be applied to a dataset in a generic way, since other functions are already in mind (moving average for instance).

fdans triaged this task as Normal priority.Sep 3 2018, 3:21 PM
fdans moved this task from Incoming to Wikistats Beta on the Analytics board.

Change 458784 had a related patch set uploaded (by Fdans; owner: Fdans):
[analytics/wikistats2@master] Add total article count metric

https://gerrit.wikimedia.org/r/458784

Nuria added a subscriber: mforns.Sep 14 2018, 12:12 PM


Total pagecounts daily seen for the last month do not really give you information when you are visualizing them (as variation is little given running totals) . I think we agreed early on that this metric only has sense if time range is hardcoded to "all" and there is no posibility to switch to a near time range. Ping @mforns to see what he thinks as he was doing CR

mforns added a comment.EditedSep 14 2018, 3:42 PM

@Nuria, I totally agree that "1-Month" is too short to percieve any change, and the graph becomes totally useless.
On the other hand, "All" has too many data points for this particular metric (even if monthly). And you can not distinguish the last data points.
You can see the slope, but not follow the recent progress of the metric.
EDIT: Actually, you can see the recent progress of the metric (my bad), but it is still too much zoomed-out I think.

Another thing that I don't like is that the dashboard is showing a mini-graph that is, in practice, static.
Any graph for "All" time range does not change much when months pass, especially one that has monthly data points since 2001. It will take around 1 year for the user to spot a little change in that mini-graph.
EDIT: Actually, that was exagerated (my bad!), but the more time passes, the more difficult will be to see new data points.

Maybe, just for cumulative metrics, we can deactivate 1-Month and 3-Month time ranges?
I need to see that properly, but intuitively think that a 2-Year time range chart for article count can still be interesting.

Milimetric assigned this task to fdans.Sep 18 2018, 1:49 PM
Milimetric raised the priority of this task from Normal to High.
Milimetric added a project: Analytics-Kanban.

See issue with table view.

We should probably link to this page somewhere in the meta page that hosts the metric definition: https://meta.wikimedia.org/wiki/Article_counts_revisited

@fdans I think table view is not a bug, rather we are displaying on table data points for which there was no value and, as you mentioned, value is displayed as zero. The issue is that this seems a mistake because the bambaran wikipedia did not existed on 2001 and thus could not possibly have a zero value for this metric, this is an issue that is also happening with other metrics in production but it is most poignant here cause we only display an "all" range.

And while the "all" range should probably be defined per wiki we use the same "start" date for all wikis. We do not have to solve the issue with this commit but I think we can probably file ticket as a bug (cc @Milimetric and @mforns )

Nuria added a comment.Sep 26 2018, 4:16 PM

We need to fix bug with '0' on dashboard

Change 458784 merged by jenkins-bot:
[analytics/wikistats2@master] Add pages to date metric

https://gerrit.wikimedia.org/r/458784

fdans moved this task from Ready to Deploy to Done on the Analytics-Kanban board.Sep 27 2018, 3:22 PM
Nuria closed this task as Resolved.Sep 28 2018, 10:42 PM
Nuria set the point value for this task to 3.