Page MenuHomePhabricator

Visual Editor works as LTR in all RTL Wikimedia wikis
Closed, ResolvedPublic

Description

When editing pages in Visual Editor, the text appears from left to right in right-to-left wikis. It's supposed to appear from right to left, of course.

This happens in all RTL wikis: Hebrew, Yiddish, Persian, Arabic. I reproduced it on Windows, Firefox 61 and Chrome 68.

From Special:Version: This in MediaWiki 1.32.0-wmf.19 (0b2f56a), VisualEditor 0.1.0 (bf9d3c1).

Marking as Unbreak Now, because it makes VE almost unusable in these wikis.

Details

Related Gerrit Patches:
mediawiki/extensions/VisualEditor : masterFix typo in mw.Target#setupSurface
mediawiki/extensions/VisualEditor : wmf/1.32.0-wmf.19Fix typo in mw.Target#setupSurface

Event Timeline

Amire80 created this task.Aug 31 2018, 5:57 AM
Restricted Application added a project: I18n. · View Herald TranscriptAug 31 2018, 5:57 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Amire80 triaged this task as Unbreak Now! priority.Aug 31 2018, 5:57 AM
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptAug 31 2018, 5:57 AM

This also set the .ve-ce-documentNode lang as en - e.g in dewiki the document language is English. (the defaults comes from 50c4efd1d5ae8942ac1284195f8a44c8e2bcd537 - though this is old change and clearly not directly blamed for this bug...)

Deskana added a subscriber: Deskana.

Needs urgent attention.

@Ryasmeen We should figure out how this slipped through QA.

Needs urgent attention.

Thanks for confirming! :)

@Ryasmeen We should figure out how this slipped through QA.

Do you have a procedure of testing on RTL? If not, I have some written docs that may help you start it.

Esanders moved this task from Incoming to In progress on the VisualEditor (Current work) board.

Change 456610 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Fix typo in mw.Target#setupSurface

https://gerrit.wikimedia.org/r/456610

Change 456610 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Fix typo in mw.Target#setupSurface

https://gerrit.wikimedia.org/r/456610

We should get this backported and deployed today, since it's a really bad breakage that we don't want hanging around over the weekend.

Definitely.

I've also added unit tests in https://gerrit.wikimedia.org/r/#/c/mediawiki/extensions/VisualEditor/+/456629/ to cover this particular issue.

We should get this backported and deployed today, since it's a really bad breakage that we don't want hanging around over the weekend.

Thank you so much <3

Change 456631 had a related patch set uploaded (by Jforrester; owner: Esanders):
[mediawiki/extensions/VisualEditor@wmf/1.32.0-wmf.19] Fix typo in mw.Target#setupSurface

https://gerrit.wikimedia.org/r/456631

Change 456631 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@wmf/1.32.0-wmf.19] Fix typo in mw.Target#setupSurface

https://gerrit.wikimedia.org/r/456631

Mentioned in SAL (#wikimedia-operations) [2018-08-31T16:30:16Z] <jforrester@deploy1001> Synchronized php-1.32.0-wmf.19/extensions/VisualEditor/modules/ve-mw/init/ve.init.mw.Target.js: Hot-deploy of I38eda4aac48 to fix T203213 (duration: 00m 54s)

Now hot-deployed to production.

Yep, verified in Hebrew, too.

Thanks for the quick fix!

Can be marked as resolved as far as I'm concerned.

Deskana closed this task as Resolved.Sep 2 2018, 12:11 PM
Deskana moved this task from QA to Product owner review on the VisualEditor (Current work) board.

Thanks for the report! Sorry about this one, folks.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptSep 2 2018, 12:11 PM

@Ryasmeen We should figure out how this slipped through QA.

Do you have a procedure of testing on RTL? If not, I have some written docs that may help you start it.

@Amire80: I don't actually. I realized it is not covered as part of my regular regression cycle. Would definitely like to get started and include it from now on.