Page MenuHomePhabricator

ORES mirrors in gerrit are not getting updated
Closed, ResolvedPublic

Description

scoring/ores/ores in gerrit supposed to be a mirror from github.com/wiki-ai/ores (that repo is now redirects to github.com/wikimedia/ores) but it hasn't got any updates in the past couple of days blocking me from testing a change on beta cluster (T201825)

Details

Related Gerrit Patches:
mediawiki/services/ores/deploy : masterUpdate ores submodule from phabricator
All-Projects : refs/meta/configDisable LFS for scoring/ores/ores

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 31 2018, 12:49 PM
Ladsgroup renamed this task from ORES mirrors in gerrit are getting updated to ORES mirrors in gerrit are not getting updated.Aug 31 2018, 12:55 PM

I think I barely remember this is due to the gerrit repo not inheriting permissions to fetch changes from GitHub. If that's so then it's easily fixable but I can't quite remember the details. @Paladox do you?

Any pointers to details or pointers to tasks with details about how this was setup would be helpful for troubleshooting. I'm familiar with gerrit -> github replication, but I don't know anything about mirroring from github -> gerrit. The only task I found about it in a quick search was T119435: Setup gerrit mirror of the repos from GitHub which was declined. FWIW, I don't see anything about ORES in the gerrit error logs dating back to 2018-08-26.

From that task:

It seems git-lfs does not have any support for mirroring. I think that we will have to roll our own solution for mirroring from github to gerrit.

@mmodell what was the solution there?

so the problem is that scoring/ores/ores doesn't need git lfs but it has it because it's inside scoring/ores/ and I don't have push right to update it. Maybe Scoring platform team should have push rights to update it from upstream (github)

@thcipriani no solution has been found yet for mirroring lfs.

Change 458278 had a related patch set uploaded (by Ladsgroup; owner: Amir Sarabadani):
[All-Projects@refs/meta/config] Disable LFS for scoring/ores/ores

https://gerrit.wikimedia.org/r/458278

Change 458278 merged by Thcipriani:
[All-Projects@refs/meta/config] Disable LFS for scoring/ores/ores

https://gerrit.wikimedia.org/r/458278

Change 458513 had a related patch set uploaded (by Ladsgroup; owner: Amir Sarabadani):
[mediawiki/services/ores/deploy@master] Update ores submodule from phabricator

https://gerrit.wikimedia.org/r/458513

Ladsgroup triaged this task as High priority.Sep 7 2018, 2:34 PM
Ladsgroup added subscribers: Halfak, greg.

Triaging this is as high since I couldn't push any change on ores not to beta or prod because of this for weeks now. The weird thing for me is that git lfs changes was mirrored to gerrit (for example you can find .gitattributes file) and that the reason we moved forward with lfs stuff but nothing has been mirrored after that. I don't have push rights to just enforce mirroring (manually) and I need to get poolcounter support out of door but I can't. cc @greg @Halfak

thcipriani lowered the priority of this task from High to Medium.Sep 7 2018, 6:01 PM

@Ladsgroup I've temporarily given the research-ores group push permissions to ref/heads/* for projects under scoring/* so that you can manually mirror. Hopefully that means you'll be fine with me lowering the priority of this task.

Since there is nothing in the gerrit logs about the scoring repositories, I would assume there is something in the phabricator logs related to the diffusion URIs that have been doing this mirroring in the past. @mmodell could you check on that?

I'm not sure, but maybe we could make this work by having Diffusion to observe the github repos, and at the same time have difussion push the changes to gerrit using {K18}? (cc. @mmodell).

thcipriani closed this task as Resolved.Sep 7 2018, 10:39 PM
thcipriani assigned this task to mmodell.

@mmodell found some suspect messages in phab.

Editing permissions for scoring seems to have done the trick!

Now: https://github.com/wikimedia/ores == https://gerrit.wikimedia.org/g/scoring/ores/ores/

Reopen if anything was missed.

It would be good if we could document for posterity how we have to configure Gerrit repos to observe from GitHub ones, and the usual troubles and how-to fix them. Wikitech is probably fine. Thanks in advance.

Change 458513 abandoned by Ladsgroup:
Update ores submodule from phabricator

https://gerrit.wikimedia.org/r/458513