Page MenuHomePhabricator

CX2: When a paragraph ends with a footnote (reference, <ref>), pressing the arrow key moves the focus to the next character
Closed, ResolvedPublic

Description

This is a follow-up to T110650, which was reported for CX1. As it is reported, it is no longer relevant in CX2, but there's a similar issue, which I'm reporting separately.

To reproduce:

  • Find an article that has many paragraphs, at least one of which ends with a reference (footnote, <ref>). (For example, Lepidoptera migration has a paragraph that starts with the words "Migration in Lepidoptera means a regular", and ends with a [1] footnote.)
  • Using CX2, translate this article into a left-to-right language, for example Polish, Hungarian, or Finnish.
  • Click the translation column ("+ Add translation") in the paragraph that corresponds to the paragraph with the footnote.
  • Put the blinking caret towards the end of the paragraph, and repeatedly press the arrow right key ( -> ) on the keyboard.

Expected: the caret moves character by character until the the end of the paragraph, after the footnote number, and after that nothing happens even when the arrow keys is pressed again repeatedly.

Observed: After several repeated key-presses on the arrow key, "+ Add translation" is shown in the next paragraph, as if it is in a hover state. Pressing the arrow key again shows "+ Add translation" in the paragraph after that, and so on.

Event Timeline

Amire80 created this task.Sep 3 2018, 2:28 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 3 2018, 2:28 PM
Pginer-WMF triaged this task as Medium priority.Sep 17 2018, 11:53 AM
Pginer-WMF moved this task from Needs Triage to CX2 on the ContentTranslation board.
Arrbee moved this task from CX2 to Check & Move on the ContentTranslation board.Feb 17 2020, 7:52 AM
Amire80 closed this task as Resolved.Aug 9 2020, 8:00 AM
Amire80 claimed this task.

Can't reproduce any longer. Works as expected.