<maplink> behavior completely destroyed
Closed, ResolvedPublic

Description

With the last deployment, the behavior of <maplink> links was completely changed and is not working any longer.

  1. The link is no link any longer. Anybody added the following stylsheet lines:
.client-js .mw-kartographer-maplink:not(.mw-kartographer-link):not(.ve-ce-focusableNode), .client-js .mw-kartographer-map:not(.mw-kartographer-link):not(.mw-kartographer-interactive) {
	pointer-events: none;
	cursor: default;
}

which means that the marker links are not working as links.

  1. The link href does not links to a map but to a special page like https://en.wikivoyage.org//wiki/Special:Map/17/30.11914/31.40073/en. That means that no real map is shown presenting all the markers given in the article.

Related Objects

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 4 2018, 6:17 AM
Aklapper triaged this task as High priority.

Confirming (removing pointer-events: none; cursor: default; makes the links clickable again).

Lofhi added a subscriber: Lofhi.Sep 4 2018, 4:39 PM

Just to make sure it's fixed everywhere: same problem on frwiki.

Gareth added a subscriber: Gareth.Sep 4 2018, 6:02 PM
Framawiki renamed this task from <maplink> behavior completely destroyed at Wikivoyage to <maplink> behavior completely destroyed.Sep 4 2018, 6:52 PM
Framawiki added a subscriber: Framawiki.
stjn added a subscriber: stjn.EditedSep 5 2018, 2:55 PM

Unless I misunderstand something, maps overall just became non-interactive: if you remove that CSS, with JS active it shouldn’t go to Special:Maps/…, it should display the map in its own modal. The issue is not in having CSS that prevents maps from being interactive before JS does its job, the issue is that JS for maps stopped loading or working.

MSantos added a subscriber: MSantos.Sep 5 2018, 3:16 PM

Change 458206 had a related patch set uploaded (by MSantos; owner: MSantos):
[mediawiki/extensions/Kartographer@master] Restoring maplink behavior

https://gerrit.wikimedia.org/r/458206

Change 458206 merged by jenkins-bot:
[mediawiki/extensions/Kartographer@master] Restoring maplink behavior

https://gerrit.wikimedia.org/r/458206

Change 458217 had a related patch set uploaded (by Krinkle; owner: MSantos):
[mediawiki/extensions/Kartographer@wmf/1.32.0-wmf.20] Restoring maplink behavior

https://gerrit.wikimedia.org/r/458217

Change 458222 had a related patch set uploaded (by MSantos; owner: MSantos):
[mediawiki/extensions/Kartographer@wmf/1.32.0-wmf.19] Restoring maplink behavior

https://gerrit.wikimedia.org/r/458222

Making a note of the conversation where this is being discussed on English Wikivoyage.

https://en.wikivoyage.org/wiki/Wikivoyage:Travellers%27_pub#POP-UP_maps_for_markers/listings

Jdforrester-WMF raised the priority of this task from High to Unbreak Now!.Sep 5 2018, 6:44 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

Fixed in master (and thus on Beta Cluster, see https://en.wikipedia.beta.wmflabs.org/wiki/MapLink. Will deploy as soon as the production deployment seat is available.

Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptSep 5 2018, 6:44 PM
MSantos moved this task from Backlog to Done on the Maps-Sprint board.Sep 5 2018, 6:47 PM

Change 458217 merged by jenkins-bot:
[mediawiki/extensions/Kartographer@wmf/1.32.0-wmf.20] Restoring maplink behavior

https://gerrit.wikimedia.org/r/458217

Change 458222 merged by jenkins-bot:
[mediawiki/extensions/Kartographer@wmf/1.32.0-wmf.19] Restoring maplink behavior

https://gerrit.wikimedia.org/r/458222

Mentioned in SAL (#wikimedia-operations) [2018-09-05T20:14:12Z] <krinkle@deploy1001> Synchronized php-1.32.0-wmf.20/extensions/Kartographer/: Ie5744d45b - T203427 (duration: 00m 58s)

Mentioned in SAL (#wikimedia-operations) [2018-09-05T20:17:57Z] <krinkle@deploy1001> Synchronized php-1.32.0-wmf.19/extensions/Kartographer/: Ie5744d45b - T203427 (duration: 00m 57s)

Framawiki closed this task as Resolved.Sep 5 2018, 8:26 PM

Fix deployed ! \o/