Page MenuHomePhabricator

REVISIONYEAR magic word returns empty result
Closed, ResolvedPublic

Description

Recently {{REVISIONYEAR}} code started to return empty values.
This leads to hundreds of broken articles in ruwiki.
This problem can be reproduced in testwiki:
https://test.wikipedia.org/wiki/User:Vort/Test

Preview works fine.
Saved article - wrong.
After ?action=purge - fine again.

Event Timeline

Vort created this task.Sep 6 2018, 3:59 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 6 2018, 3:59 PM

Confirming for my sandbox page on mediawiki.org

greg added a subscriber: greg.Sep 6 2018, 4:26 PM

When did this stop working?

Vort added a comment.Sep 6 2018, 4:31 PM

First report was made ~3 hours ago (13:46 UTC) at ruwiki forum.

Tgr added a subscriber: Tgr.

This is about the initial rendering of the page, not the substed wikitext, so definitely a different bug.

Aklapper triaged this task as High priority.Sep 6 2018, 10:04 PM
Vort added a comment.Sep 7 2018, 6:30 AM

Can't reproduce anymore.

Tgr closed this task as Resolved.Sep 7 2018, 9:01 AM
Tgr claimed this task.

The fix for T203583 injects the current timestamp before parse, this was probably fixed by that (I can't reproduce either). Please reopen if you still see it in the wild.