Page MenuHomePhabricator

Date not when adding a citation automatically in Citoid powered by Zotero
Closed, DuplicatePublic

Description

When adding a citation in the Visual Editor automatically using Citoid, the date parameter is not set correctly when using a PMID, and possibly other automatic formats.

For example, when the PMID 23617693 is used for this article in Citoid the red text error Check date values in: |date= (help) is shown. I click Insert, then Edit and see that the date (shown as 2014 Jun in the article) is stored as 2014-6 in the date parameter which clearly is unable to be interpreted as June 2014.

Here is a screenshot of the displayed red text error.

Event Timeline

Waddie96 created this task.Sep 6 2018, 7:58 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 6 2018, 7:58 PM
Waddie96 updated the task description. (Show Details)Sep 6 2018, 7:59 PM
Waddie96 updated the task description. (Show Details)
Waddie96 updated the task description. (Show Details)
Deskana added a subscriber: Deskana.

This issue appears to be in Citoid itself, not VisualEditor, so I've removed those tags.

Izno moved this task from Unsorted backlog to External on the Cite board.Sep 11 2018, 7:39 PM
Mvolz removed a project: Cite.
Mvolz added a subscriber: Mvolz.Sep 12 2018, 1:00 PM

I agree this is really annoying. The problem is we never really reached a consensus on how to handle dates that were only the year and the month, which is the task I just merged this one into.

We ended up deciding not to validate them at all rather than coerce say 2001-05 into 2001-05-01 which gives false precision. But what this means is a large number of dates are these partial ISO dates which then users have to manually translate to English dates. The error is coming from the citation template which does not accept partial ISO dates containing only the year and the month as valid.