Page MenuHomePhabricator

Button to open complete list of languages is no longer functional on en-Wiki
Closed, ResolvedPublic

Description

The button to show all languages in a compact language list is no longer working on English Wikipedia. For example, clicking on "12 more" in the language list at https://en.wikipedia.org/wiki/Wikipedia:Teahouse does nothing. See also https://en.wikipedia.org/w/index.php?title=Wikipedia:Teahouse&oldid=858357806 (section "language links" at bottom) for similar reports from other users.

The "Use a compact language list" setting in Special:Preferences --> "Appearances" is checked.

System settings: Vector skin, Firefox 52.9 (possibly also on Chrome, as reported by another user - see Teahouse thread link).

Event Timeline

GermanJoe created this task.Sep 7 2018, 7:43 AM
Restricted Application added a project: UniversalLanguageSelector. · View Herald TranscriptSep 7 2018, 7:43 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
GermanJoe updated the task description. (Show Details)Sep 7 2018, 7:51 AM
Nikerabbit triaged this task as Unbreak Now! priority.Sep 7 2018, 7:53 AM
Nikerabbit added a subscriber: Nikerabbit.
TypeError: Cannot read property 'interlanguageList' of undefined
    at ext.uls.compactlinks.js?ccaab:218
    at Array.forEach (<anonymous>)
    at CompactInterlanguageList.createSelector (ext.uls.compactlinks.js?ccaab:217)
    at ext.uls.compactlinks.js?ccaab:315
    at fire (jquery.js?09dd6:3317)
    at Object.fireWith [as resolveWith] (jquery.js?09dd6:3447)
    at Object.deferred.(/w/anonymous function) [as resolve] (https://en.wikipedia.org/w/resources/lib/jquery/jquery.js?09dd6:3778:36)
    at Object.ready (mediawiki.base.js?01e5b:633)
    at handlePending (load.php?debug=true&lang=en&modules=startup&only=scripts&skin=vector:11812)
    at markModuleReady (load.php?debug=true&lang=en&modules=startup&only=scripts&skin=vector:12146)
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptSep 7 2018, 7:53 AM
Amire80 added a subscriber: Amire80.Sep 7 2018, 7:53 AM

Uh-oh, I can reproduce it. Thanks for the report. We'll check this as soon as possible.

Change 458725 had a related patch set uploaded (by Amire80; owner: Amire80):
[mediawiki/extensions/UniversalLanguageSelector@master] Revert "Simplify by using native JavaScript instead of jQuery"

https://gerrit.wikimedia.org/r/458725

Change 458728 had a related patch set uploaded (by Fomafix; owner: Fomafix):
[mediawiki/extensions/UniversalLanguageSelector@master] Fix JavaScript error in compactlinks

https://gerrit.wikimedia.org/r/458728

Change 458728 abandoned by Fomafix:
Fix JavaScript error in compactlinks

Reason:
https://gerrit.wikimedia.org/r/458725 reverts 0fbdbc2c41.

https://gerrit.wikimedia.org/r/458728

Change 458725 merged by jenkins-bot:
[mediawiki/extensions/UniversalLanguageSelector@master] Revert "Simplify by using native JavaScript instead of jQuery"

https://gerrit.wikimedia.org/r/458725

Change 458743 had a related patch set uploaded (by Hashar; owner: Amire80):
[mediawiki/extensions/UniversalLanguageSelector@wmf/1.32.0-wmf.20] Revert "Simplify by using native JavaScript instead of jQuery"

https://gerrit.wikimedia.org/r/458743

Change 458743 merged by jenkins-bot:
[mediawiki/extensions/UniversalLanguageSelector@wmf/1.32.0-wmf.20] Revert "Simplify by using native JavaScript instead of jQuery"

https://gerrit.wikimedia.org/r/458743

hashar added a subscriber: hashar.Sep 7 2018, 9:37 AM

With firefox I had:

Exception in load-callback in module ext.uls.mediawiki:   TypeError: this is undefined

Mentioned in SAL (#wikimedia-operations) [2018-09-07T09:38:52Z] <hashar@deploy1001> Synchronized php-1.32.0-wmf.20/extensions/UniversalLanguageSelector: Revert "Simplify by using native JavaScript instead of jQuery" - T203750 (duration: 00m 55s)

Amire80 closed this task as Resolved.Sep 7 2018, 9:49 AM
Amire80 claimed this task.
Amire80 added a subscriber: Fomafix.

The fix is deployed to production. Thanks @GermanJoe again for the report, and thanks to @hashar for the deployment!

@Fomafix, we'll review your other fix separately. Since the bug is resolved in production, I'm closing this.

Amire80 moved this task from Backlog to Missing languages on the ULS-CompactLinks board.
Amire80 moved this task from Backlog to Compact Language Links on the UniversalLanguageSelector board.