Page MenuHomePhabricator

Allow configuring GeoCrumbs to be used in name spaces other than the main space
Closed, DeclinedPublic

Description

Like the title says. There are other extensions that do something similar: WikidataPageBanner, VisualEditor and Flow.

For example $wgGeoCrumbsAvailableNamespaces = (NS_Book; NS_Guide)

In spanish: GeoCrumbs debe poderse configurar en otros espacios de nombres como el espacio de nombres Guía o Info bajo la configuración adecuada.

Event Timeline

Hispano76 created this task.Sep 7 2018, 1:11 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 7 2018, 1:11 PM
Hispano76 triaged this task as Medium priority.Sep 7 2018, 1:12 PM
Aklapper raised the priority of this task from Medium to Needs Triage.Sep 7 2018, 2:28 PM

Resetting priority.

This task sounds like a support question ("How can I do...?") for https://www.mediawiki.org/wiki/Extension_talk:GeoCrumbs or https://www.mediawiki.org/wiki/Project:Support_desk but not like a bug report or feature request? :)

If I understand T47665 correctly the current behavior is intentional.

Which MediaWiki version is this about? Which extension version is this about? Also see https://mediawiki.org/wiki/How_to_report_a_bug - thanks!

@Aklapper Yeah, it's a support question hehe. Sorry, it's the first time I've opened a thread here. As I didn't know where to ask because the discussion page is very abandoned and it wasn't clear to me who the authors were. I decided to ask in Phabricator.

MediaWiki version is 1.31.0 (59f789d).

GeoCrumbs extension version is 2.0.0 (f d7e115).

The only temporary solution is to create a redirection (List:Example to Example) and in List:TestArticle add {{Isin|List:Example}} to make it work.

Aklapper closed this task as Invalid.Dec 11 2019, 12:39 PM

@Hispano76: Nothing, see the previous comments in this task. :) I'm also closing this task as invalid, as it is not a bug report or feature request.

@Aklapper Technically I consider it a bug but good. Thank you for responding. :)

@Hispano76: I don't see a bug... If this is a feature request, feel free to reset the task status to "open" and rephrase the task summary to something like Allowing having GeoCrumbs enabled in other name spaces with a tag similar to wmgVisualEditorAvailableNamespaces or such, via Edit Task in the upper right corner. Thanks! :)

Hispano76 renamed this task from It is possible to have GeoCrumbs enabled in other name spaces with a tag similar to wmgVisualEditorAvailableNamespaces to GeoCrumbs must be configured to be used in name spaces other than the main space.Dec 19 2019, 7:14 PM
Hispano76 reopened this task as Open.
Hispano76 updated the task description. (Show Details)

@Hispano76: I don't see a bug... If this is a feature request, feel free to reset the task status to "open" and rephrase the task summary to something like Allowing having GeoCrumbs enabled in other name spaces with a tag similar to wmgVisualEditorAvailableNamespaces or such, via Edit Task in the upper right corner. Thanks! :)

Done

Aklapper renamed this task from GeoCrumbs must be configured to be used in name spaces other than the main space to Allow configuring GeoCrumbs to be used in name spaces other than the main space.Dec 19 2019, 7:50 PM

Was there any news about this?

@Hispano76: No (and there is no need to ask). You or anyone else is welcome to work on fixing this task, if you/they want to see this task fixed. Thanks!

Hispano76 closed this task as Declined.May 7 2020, 5:15 PM

I prefer to close this, I'll do it another way (by navbox)